Game not rendering/displaying when testing

#1

I’ve been attempting to prototype a stationary first person zombie shooter. I created a plane, light, player box, and camera. Using logic nodes, I created a simple mouse look script. After ensuring that the cycles rendering engine was selected, I clicked play and all i got was a grey screen. This is odd because I’ve tried this before and it worked fine. But after adding some color to the plane everything went wrong. I completely deleted Armory and reinstalled it, but when I setup a scene like I described earlier (minus any color), I still get a grey screen. I do have GPU selected instead of processor, if that matters. Any ideas?
P.S. When I get to my computer I can upload some screenshots if needed.

0 Likes

#2

I would try running an Armory example, such as the animation example to see if that displays properly. If it does, we’ll know that it is specific to your Blend file. Also, if you don’t mind, uploading the blend that you can’t get working could be useful.

The Cycles/Eevee settings don’t actually effect Armory because Armory uses it own Renderer, so that shouldn’t be a problem.

0 Likes

#3

Thank you for your input. I truly appreciate it. I’m heading over to the Armory website now to grab one of the examples to test things out. If the example works, I’ll for sure upload my blend. Again, thank you.

1 Like

#4

attempt3.blend (945.2 KB)
Here’s my blend file. The playground example seemed to run fine, and my blend is perfectly viewable through the viewport, however, as soon as I try to use the scene, everything goes south. I’m totally lost.

0 Likes

#5

Hey @xPenguinx, I figured it out! The problem is that the cube that you have the camera parented to has a scale that is not (1, 1, 1). I think Armory has problems in general when an object’s scale is not 1.

What I did was click on the cube, and use Ctrl-A to bring up the Apply menu and select “Scale”, to set the scale to 1 without changing the shape or size of the object. After you do that, you will notice that the camera gets re-positioned to the inside of the cube. That is why you were getting the light-grey screen when you ran the game.

I also set the scale on the camera to 1, 1, 1 manually in the object panel. That may not be necessary, but it is usually good to keep things as clean as possible so that they don’t cause you trouble later, especially with Armory because it doesn’t always behave exactly the same as Blender.

After that just move the camera back to where you had it initially and everything should work!

0 Likes

#6

You are officially my favorite person! Thank you!

0 Likes

#7

Glory to God. I’m glad I could help. :slightly_smiling_face:

0 Likes

#8

After setting my scales to 1,1,1 and moving the camera back into position, I’m still getting a white screen. However, if I disable update to the camera rotation (x axis) then the scene displays fine. But with the camera update disabled, I can’t rotate the view at all; despite the update remaining on the (y axis) rotation of the Player Cube. Maybe this has to do with the fact that I’m using nodes instead of a haxes script. IDK. Back to the drawing board I guess.

0 Likes

#9

Logic nodes are actually only creating Haxe scripts for you automatically, so there shouldn’t be a problem there other than the possibility that the overall strategy you are using is wrong conceptually.

Taking just the steps I outlined above it works for me. I can walk and look around, too. Here is the blend:

attempt3(1).blend (941.5 KB)

0 Likes

#10

When I get back to my computer I’ll check it out. I used the fps logic node thread here on the forums to create the camera look logic. It does say “no longer recommended” though. I’m curious if I either:
a) moved the on update node back in the tree somewhere or
b) made the camera a child of another object (ie an empty) and rotated that, if it would help any.
I’ll for sure check your blend file first and see what’s what.

1 Like