How to get code completion when using Kode Studio?


#1

Hello, my name is Argos and I’m new here.

I’m following tutorial 1.

Kode Studio window opens as I expected but vshaxe wheel keeps spinning below and it blocks any code completion:

What should I do to complete initialization process and get code completion?


#2

It seems like pressing the “Play in Viewport” button once before hitting the “Edit Script” button creates all necessary Kode Studio project configuration files.


#3

Yes, Kode Studio needs a build to be done before code completion start working.


#4

Will look for a way to quickly auto-generate build file when opening Kode Studio from Blender, so it can pick it up for code completition.


#5

Hello! Was this issue resolved? I’m having the same problem in latest build: Haxe completion cannot properly finish.

EDIT: same thing both on Linux and Windows in my case.


#6

@tito maybe help you, if you install kode studio apart you keep autocompletion as well as jump to definitions/ declarations …


#7

Strangely enough, the issue has been resolved after installation purge. Thanks for help, @Didier.

EDIT:
I stumbled upon this issue once more on different machine. This time I’m quite certain what is the cause of the problem. I was tinkering with Kha some time ago, thus I had Kode Studio and Haxe installed. It seems like some old Kode Studio setting was pointing to old Haxe installation, and this caused the problems with code completion (and other things). So, removing old Kode Studio completely (along with settings in User directory) solved the problem.

TL;DR
If you cannot make code completion working and was using Kode Studio before, make sure to remove Kode Studio settings directory in User folder.