The problem with exporting to html5 (v0.5)


#1

When exporting to xml5, it displays errors and displays a black screen:

  1. Sampler gbufferD not found
  2. Uniform textSize notfound

in the Krom scene is displayed well


#2

Sometimes you need to empty the browser cache and make a clic on the “clean project” to see everything going well on Html5 … same thing when you don’t see a modification to happen in the browser.


#3

Tried it. Does not work even in a new cube scene.


#4

maybe something in relation with differences between Blender version 2.8 and preceeding versions … if so, try to delete some predefined objects/shapes/mesh… that could have change in the 2.8


#5

Even the new default scene with a cube or any new object does not work.
Wrote to Lubos. Everything works for him. The problem is on my side. looking for. Thnx!


#6

(Investigating at #861 if anyone runs into the same issue.)


#7

found the reason.
In the renderer settings, if the “deferred” button is active, it does not work.
If you put “forward” - it works


#8

when reporting HTLM5 issues please include System information (os, browser & version, graphics card, etc)

it would also help if you could attach a zip with the scene file so others can test it.

(which apparently you did in the github forum)

keep in mind that the “deferred” render path requires a webgl2 capable browser/device, otherwise it will report errors in the console and display a black screen.

always try the “forward” render path before reporting
or the “low”/“mobile” for mobiles

cheers


#9

on my computer in Linux systems and windows - everything works well.
I asked several friends to test the scene and in 6/10 it did not work.
I do not know what systems and browsers are on their computers.
Maybe it’s really in webgl2