Adding a shader to a mesh causes an error

For some reason beginning today, whenever I add a shader to a mesh, I get the following error

Uncaught exception:
Krom.compilePipeline(this.pipeline,structure0,structure1,structure2,structure3,this.inputLayout.length,this.vertexShader.shader,this.fragmentShader.shader,gs,tcs,tes,{ cullMode : kha_graphics4_PipelineState.convertCullMode(this.cullMode), depthWrite : this.depthWrite, depthMode : kha_graphics4_PipelineState.convertCompareMode(this.depthMode), stencilMode : kha_graphics4_PipelineState.convertCompareMode(this.stencilMode), stencilBothPass : kha_graphics4_PipelineState.convertStencilAction(this.stencilBothPass), stencilDepthFail : kha_graphics4_PipelineState.convertStencilAction(this.stencilDepthFail), stencilFail : kha_graphics4_PipelineState.convertStencilAction(this.stencilFail), stencilReferenceValue : stencilReferenceValue, stencilReadMask : this.stencilReadMask, stencilWriteMask : this.stencilWriteMask, blendSource : kha_graphics4_PipelineState.convertBlendingFactor(this.blendSource), blendDestination : kha_graphics4_PipelineState.convertBlendingFactor(this.blendDestination), alphaBlendSource : kha_graph%s
TypeError: Unable to get property ‘shader’ of undefined or null reference
at compile (krom.js:35295:3)
at iron_data_ShaderContext.prototype.finishCompile (krom.js:7689:3)
at iron_data_ShaderContext.prototype.compile (krom.js:7680:4)
at iron_data_ShaderContext (krom.js:7519:2)
at iron_data_ShaderData (krom.js:7464:3)
at Anonymous function (krom.js:7484:3)
at iron_data_Data.returnSceneRaw (krom.js:6301:3)
at Anonymous function (krom.js:6285:3)
at Anonymous function (krom.js:6451:4)
at kha_LoaderImpl.loadBlobFromDescription (krom.js:23338:2)

Ive tried and tried to get this to work, including stripping out all the materials and re-starting. Some of them work with no problem

Here is a copy of the blend file with the working shaders in it, its too big to upload directly here (about 10mb) so its on my google drive

the specific mesh that I am trying to add the shader to is the one titled Cube in the Bathroom Collection which is under Mezzanine in the scene collection – any time I try to put a shader on it (it currently has one called material) and then play the game, it shows only black on the KROM screen

Im often on discord too if you want to chat about it

Usually am undefined/null error means something in the node tree is missing a node being plugged in where it expects, or that is getting a different type of node plugged in than what it needs (eg there’s a shader plugged in where it needs an RGB value or vice versa).

Are you applying a material that works elsewhere?

Yes, the exact same materials work just fine in a different file (a simple cube with one cam and one lamp)