Armory Player doesn't work

I just started with Armory 3D but I’ve run into an immediate and pressing problem. Choosing the “Play” option in the Armory Player will not work. I’ve tried running it on Krom, C++, and in Browser, and each time, the screen is black. I downloaded one of the Armory 3D demo files, but when I click on the game.exe, it loads a Krom window with a black screen that immediately closes a few seconds later. So, clearly I cannot play anything.

Some of my PC specs:
ADM A8-6500 APU with Radeon ™ HD graphics (3.5 ghz)
32.0 GB of RAM
NVIDIA GeForce 9500 GT

My graphics card is out of date and I am not even sure if it’s capable of handling this. Blender can’t actually use my graphics card to render anyway. But I’ve been told that Armory 3D should still be working. I am frustrated… can someone please help? I can’t find anything anywhere else.

I’ve actually noticed that one of my older windows machines won’t play Armory games either. It just gives a black screen. I don’t remember what the card was on that computer, but I’m pretty sure it was also an Nvidia GeForce ( I don’t know what the number was offhand ).

That is a better system then mine and I can get it to work. What operating system are you using?

It’s a very old 3D card.

But you should be able to run Armory because Armory 3D supports mobile games with very basic lighting.

I am using a recently-updated version of Windows 10. So this is quite strange and admittedly kind of frustrating. I am wondering what other settings or presets are somehow interfering with this. There technically must be some reason…

I looked through this helpful conversation and found a useful fact:
my OpenGL is version 3.3, whereas Armory 3D recommends version 4.4 . It does say “recommended” though, so I am not sure if it’s still supposed to work or not. I looked at other suggestions and changed certain settings with no luck. If it turns out that I need a higher version of OpenGL then that means I’ll need a new graphics card… which is a goal for me anyway.

You don’t necessarily need a new graphics card to get a newer version of OpenGL. In some cases at least, it is possible to update your software and drivers to run the latest version of OpenGL even on somewhat older cards. For example for my Linux laptop, if I run glxinfo | grep -i opengl it will have the following lines in it:

OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL version string: 3.0 Mesa 18.0.5

The second line shows the version of OpenGL that my graphics card runs by itself, and the first line shows the core profile version which is higher because I have updated software. I don’t understand it completely, but I do know that after updating my software, my card is compatible with OpenGL 4.5 even though some features don’t actually work like VoxelGI.

You can also try running Armory with the Legacy Shaders option. It is in the Armory settings in the addon panel in blender. It will compile the shaders to an older version of OpenGL which could help for older cards, but it might also cause graphics issues or just cause some features to not work ( like VoxelGI ).

the Legacy Shaders option was applied. But I do not think it is possible to update my current card to run the latest version of OpenGL. That’s what it seems, at least. Then again, I don’t even know how to do that.

I think for my Linux laptop it actually came with later versions of the kernel, but I have no idea what it is like for Windows.