Armory3D/Blender - Can't Set CUDA in User Preferences

Hello. I recently downloaded Armory3D (the version with Blender 2.79). When I go to User Preferences>System to check my setup, under Cycles Compute Device it only has “None”. On my regular Blender install I can select CUDA since I have a compatible device (Nvidia GeForce 1070). Why isn’t this option available in the Blender that comes with Armory3D?


We need to compile Blender with some additional setup for CUDA, it’s my fault that I still did not address this. A possible ‘fix’ is to use Armory in regular Blender (with no viewport player).

Still aim to fix it, as soon as the current transition to b2.8 settles up. (Armory 0.4 will come with both b2.79 and b2.8 support).

1 Like

Thanks! I’m excited about Armory3D and look forward to what you do with it.