Build12 Sound examples does not work

I’m testing the sound example from github but it does not play any sound when I clicking anywhere with my mouse. Is this a bug ?

In Build 13 the sound should now work properly in Browser, Krom (Windows + Linux) and C++ targets.

Built-in Armory player in Blender to go next. :slight_smile:

1 Like

Hey Lubos
No Sound either in the example file or in my Project Sound didnt work and i get a black screen every time i start krom,browser ( build 14) if i delete the Speaker the Blackscreen is gone did i make something wrong.

Same here, any luck with the new armory v0.1 running in stand-alone Krom window(F5)?

You might also try setting Armory Project - Sound Quality to 1.0. This will make it use .wavs directly, instead of converting to .ogg. Both of these options should work, if it still crashes then it’s a bug in Armory.

hey Lubos

Is there a way to disable sound at start if i add a sound it start to play every time and its overlap because of the scene restart , if i restart a scene with set scene it set the position of the player but not all of the content in the scene was restart its looks that sometimes the scene overlapping several times, the scene restart or set is a little bit buggy.

Hey @kotarosdevgame,

I have added an option to disable sound by setting Properties - Render - Armory Project - Audio to Disabled. Note this is in the latest git version. I will also check on the Set Scene node, thanks for letting me know!

Hey Lubos

sry for disturb again i change the code you post in github with the exitsing code from

it give me an error in many lines at least i read in console cant find arm_ audio

Not disturbing at all! If you want to do it by hand you need to apply all the changes, the commits are:

But there is an easier way:

(Note: v0.1b contains (another) updater fix for Windows, which so far seems to work. :slight_smile: )

@lubos, I noticed that v0.1b will always updates even I already have the latest git version. This is new behavior ?

Yes, at least for the time being. If this works reliably I will eventually make it more clever and reclone only when needed. Previous updater had trouble sometimes not being able to pull, and it caused a nightmare to pinpoint a bug report then.

It is still possible to pull manually, git pull from the command line in armsdk/armory and armsdk/iron folders.

Hey Lubos

Sry but the Audio disable option isnt in the last build release on itch .

Disable Audio close the Sound generally and play on start is an good option for short fx sounds.

But if i restart the Scene over and over again the last Soundtrack i have played didnt close, it Overlap

the previous Soundtrack, its very important for Games who use Soundtrack inside.

for Info ,i use the latest git version.