Greetings and problem

Hi! I just signed up in the forum so greetings to everyone. This project looks great, I really hope to see it progress and flourish!

Now, my problem. I am not very accustomed to armory, so I might be doing something quite stupid. However I did some tutorial and small exercise with armory 01, so at least I managed to make it work.
In short, I open a new, empty project, just add a cube and a camera, try to see the viewport preview (or any other mode to run the game) and I get this error in the console:

C:\Program Files\Blender\Armory\armsdk\armory\Sources/armory/trait/MirrorTexture.hx:18: characters 14-65 : has no field mirror

Finished in 2.8606393337249756
Build failed, check console

What am I doing wrong?

Thanks for any help! :slight_smile:

EDIT: just tried armory 01b and it works fine…

Normally when I face issues building (on linux) I will

  1. delete my home/user/.config/blender folder
  2. update SDK in the addons
  3. if updating doesnt work I restore SDK

One of the three will always resolve building issues for me. For future reference.

hi breebee, thank you very much for your help!

  1. won’t this method delete my settings for all the other blender 2.79 builds I use on my computer? I’d like not to reset my blender config for the other builds. EDIT: just tried to temporarily move the settings elsewhere, but this did not solve the problem.

2,3. Sorry… as I said I am quite a noob for things not directly related to graphic. How do I update or restor the SDK? I can see an armsdk folder inside the blender armory folder, but I don’t really know what to do with it.

I should’ve probably mentioned that I am on Win10

EDIT: ok, I tried to download 04lite and it’s working fine now. by restoring the SDK did you mean just unzip the package again?

I am going to keep asking generic (noob :smiley: ) questions in this topic, in case there’s a better place for that please let me know.

when I get a build failed error in the blender console, I see written “check console”… what console is the message referring to?

Other question: in Armory 01b when clicking edit script in Armory traits panel, the Kode studio opened. In 04 windows asks me what program I would like to use to open the file. Problem is I don’t know where the kode studio is installed (I don’t think I ever installed it, I think it came bundled with armory). What to do here?

Generally in linux I will run armory with the terminal (command prompt in windows).
cd /location/of/blenderarmory
and you will see everything going on from compiling shaders to errors ect. I believe in windows you just
cd /location/of/blenderarmory
without the ./ in front of it to run it. That will give you everything going on, otherwise you can pull down the blender console from the top menu bar, or in case they changed that you can set one of the windows, for example the timeline, to a blender console. Not sure about your Kode studio issue, try installing kode studio manually, or better yet toss windows completely and move to linux :slight_smile:

Oh and for your previous question above I did not see, to update/restore your sdk go to your preferences -> addons (filter “armory”) and you will see update/restore buttons in 04 build.

tried to launch from command line. I actually had to use ./blender because I have another version of blender set in the environment variables for when I render from command line. Unfortunately the console works exactly the same as when I activate it from “window>toggle system console” inside blender. It shows me all the things like shader compiling and so on. It’s just that when there is an error he tells me to check the console :smiley: I wonder if that’s just the way it works, or if there’s actually a place where it give more info.

I tried linux several time. In general I like it, but I also use windows only programs and games, so I feel at the end of the day it would just be a pain and a lot of time spent trying to make things work instead of actually working.

thanks for the restore\update sdk hint, this works perfectly!

Now I need to learn this engine! :smiley:

do all the templates files work for you? I get build failed with the FPS, third person and cell shading template. The archery and the car tamplates works fine

and thank you for all the help you are giving me breebee :slight_smile:

Yes I figured you had another instance of blender conflicting. I suppose your console not logging correctly in the current terminal may be relative to that? Generally armory spits out a modal pop out window with the error traces without the terminal from inside blender which should give you information. Someone with better knowledge will have to suggest what to do or try the github and submit an error. Maybe try blender with ./blender --verbose or something.

Yes all the templates work fine for me, I simply have to repeat the steps in deleting my blender config files, or update/restore sdk ect. Allot of the time I forget to turn off the default “auto save on build” in armory and when you mess something up the only way to fix it is figuring out what you messed up, cant just reopen the project. Really bad default setting in my opinion. Especially when learning Armory. So maybe just re-download the template in case you were not aware of that setting.

the behavior of armory at the moment feels a bit erratic. The main reason for this is surely my complete lack of experience. However I downloaded 04 and I couldn’t open the script editor. Then I downloaded 03 and the editor worked but I could’t compile many of the demos. Then I updated again through the update SDK option to 04. Now I can open the editor and the demos works.

Then I had some problem where a material that worked perfectly started to appear as completely black. The only way I had to fix it was to give the object a new material all together, but from time to time I still get the same problem.

Anyway… I said lot of this is probably due to my experience. Armory is in beta anyway, so it’s also normal to have stuff not perfectly working yet.

Problem is I have so many questions I don’t know where to start from :smiley:

The code editor is now present in armory_04_b27 builds, hopefully that fixes the original issue. :slight_smile:

Also created an issue to make Save on Build turned off by default.

1 Like

hi Lubos! thanks for update and for all the great work! :slight_smile:

1 Like