Having troubles with animations in Krom

Ok so I made a character and rigged it up. I made an idle animation and it works fine in Blender. But when I press play and Krom shows up it turns out to be really messed up. I have no idea what happened and I need some help because I’m not so good with this. Also I just made an account so I can ask for help here and it wont let me upload attachments so here’s a google drive folder that has the project and some photos.


I managed to fix it, here it is working.

file: LowPoly Character fixed.blend (2.2 MB)

What i did was:

  1. Apply the mirror modifier in your character mesh. Armory currently doesn’t support yet having other modifiers alongside an Armature one. So you should apply the other ones to have the same result in Krom that is visible in Blender.
  2. Animations and scales don’t like each other, with that in mind, the first thing I looked in your file is the scale of your rig and the scale of your mesh. Your rig has (1.0, 1.0, 1.0) which is ok, but your mesh had (0.48, 0.48, 0.48).
    After that what I did:
    a. First I cleared the parent of the mesh. for that I chose Clear Parent and Keep Transformation to avoid breaking stuff the least possible.
    b. After that I applied the scale of the mesh to have it (1.0, 1.0, 1.0).
    c. As a final step I reparented the mesh to the rig with Automatic Weights for testing purposes.

And after those steps it seems it’s working.

As a sidenote: don’t forget to clean the cache with the Clean button that is next to the Play one to purge old caches that remains from previous build. Maybe it may work fine this time, but in general cache could cause some issues too.


Thank you so much for your help I see in your gif that it’s working. However in my computer it still doesn’t show the whole body. I don’t know if there’s a difference between your Krom and mine. I updated the google drive folder with a new picture and your fix. Again I really appreciate your help on this.


Did you try this? maybe the issue is around the cache.

Ok so I tried to do this whole process in another computer to compare the results. I got it working in my friend’s computer just fine, so I’m assuming something is up with my computer that I should look into another time. Anyway thank you so much for your help!

Try clearing the scene. Press the button(Purge) several times.

03 39

Again, sounds like the left overs from previous builds are causing the issue. Try clicking this button with your project open.

It will delete left overs that are generated when building the project: shaders, meshes, etc., to force a recompile whenever you build your project again.

If you saved your project in …\my_project\my_project.blend then when you hit play it will compile the assets to \my_project\my_project_build\ folder. With the Clean button it will remove leftovers from that folder.