Help to start the tests

Hello, I’m a big fan of blender so I think the design of the Armory is incredible.
I am a programmer for many years but a beginner in programming for games and OpenGL.

Can anyone help me understand why I can not play Armory on my Linux (Fedora 26)? It does not work either in the window inside Blender (F5) nor after it has been published.

I’ve tested several Path options, including Mobile.

From what I understand the error is related to my video card does not support the required OpenGL, I actually use a good noteboot however it does not have a real video card. My goal is to test the Armory logic nodes that I believe are as good as the Unreal Blueprints, and do basic tests on mobile games, so my goal at the moment is not to buy a Quadro 1000 card just for that.

Is it really necessary to have minimal hardware to run the Armory, even in the most basic Path, or is it some problem that I have to solve?

The error is this
GLSL compiler error: 0: 1 (10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, and 3.00 ES

The way out of my glxinfo is this
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Intel ® DRI Table Ivybridge Mobile
OpenGL core profile version string: 4.2 (Core Profile) Table 17.2.4
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Table 17.2.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Table 17.2.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Thank you

Hello, i’m running Armory with Fedora 27 and AMDGPU Mesa driver ( i use AMD RX580).
I tried also Armory also with an old iMac® with AMD 4670 with 256 MB Vram and it worked with simple forward Path.

About your issue i hope that @lubos can help you more.


After I sent the post I did some more research and found the solution.
Just go to the user preferences, select the Armory plugin, and in the advanced settings activate Legacy Shaders.

For me it worked perfectly, hope it works for you too.