Issues with Keyboard, "q" not releasing

Hello Armory community,

I wanted to know if anybody has noticed a malfunction with their “q” key on Keyboard ?
With the node “on keyboard”“down” if you hit “q” it wont register the release state.

Also I checked with a Haxe Script

notifyOnUpdate(function() {
	var kb = Input.getKeyboard();
	if (kb.down("q")){ trace('q'); }

but it’s not working either.

I tested LinuxMint with ArmorySDK1910, can anyone tell me if they have the same issue, even on other OS thanks.

You need to specify that it is the key release you are wanting an output from. You can use kb.down(“q”) to send an output whenever the key is held. kb.started(“q”) to send an output when the key is first pressed. or kb.released(“q”) to send an output when the key is released.

1 Like

Thank you for your answer,

I tried with “down”,“started” and “released”, but it’s still not working:
Down : it should print “q” as long as keyQ is pressed, but it never stop to print ( even when the keyQ is released ).
Started : it should print “q” each time keyQ is hit, but it print it only once ( even if I hit it multiple times ).
Released : it should print “q” when keyQ is released, but it’s not printing anything.

All other Keys seems to work though.

I looked in “iron.system.Input” and compared it with older versions to see if there were any differences, but I could’nt find anything.

The problem must be on higher level, but I don’t where to search…

1 Like

That’s very odd, could possibly be a bug? might be worth posting an issue on github -

I thought so… I just wanted to know if other people had encounter the same issue before reporting it on github, as it could have been a problem just with my configuration.

I’ll post it, thanks for the help :slight_smile:

1 Like

I am using Linux Mint and it is the same state. There is no problem with Windows 10.

On Linux, it seems to be detected that the “o” key is released when the “q” key is released. You can check the Haxe code that you created with a slight change.

notifyOnUpdate(function() {
	var kb = Input.getKeyboard();
	if (kb.started("q")){ trace('q'); }
	if (kb.released("o")){ trace('o'); }

I didn’t notice the problem with the “q” key, but on Linux there was a problem with “escape”, “comma”, “period”, which I have reported.

According to the information received there, it seems to be influenced by Kha, so I have reported it to kha. I also reported the information on this page.

1 Like

Thanks a lot Sandy,

Indeed when the Key Q is released “o” is printed instead… I didn’t know about “coma”, “escape” and “period” either…
I checked the Armory3D issues to see if anybody had reported it there, but I didn’t think about checking Kha’s issues.

1 Like

Armory2019.11 can detect Linux (Krom) Q key release. Thank you for the important report.