Larger mesh not render in krom

Hi when i import mesh terrain into template, it works in template player nice, but when the mesh is larger like 500m it actually shows only black screen … not sure how to debug this whole thing as console looks without error :sunny:

Hi apofyz,

could you provide your .blend file ? I will test it on my PC…maybe it can help you

Hi Petit, thank you for your attention, here is the blend with large mesh!McK5z9X4aIRe/vehicle-blend

if i replace this one with 250m diameter mesh it works… but this one 1000m does only black screen and i tried 500m which does not work too

Hi apofyz,

I have downloaded your file (hopfully, english version was possible, because I do not speak czech !)
I was not able to compile your file. This is because blender do not find the textures files. For next time, please provide the blend file with the files attached. For that, you need to do:
File > External data > Automatically Pack into .blend
…and you save your blend file (it will attached all the texture files inside)

I have created a material without texture and applied it to all the objects of your scene.
Then I had an other error with “TypeCar” (or something like that) not detected…I have removed your car…
Compilation now works !
But I have an awful screen whatever the size of your mesh…The console tells me that there is an array issue (memory…).

Could you simplify your blend file (remove all the useless objects) and reduce the mesh size of your ground ? And send it again ?
thanks !

Hi apofyz,

I have your answer ! I have imported your mesh called “Grid” in a scene, which is compiled, and here is the result:

  • whatever the size (1000mx1000m, or 250mx250m), I have this awful result on the realtime window:
  • if I reduce the size of the vertices of the mesh (with the Remesh modifier), then the display is OK. Apparently, a mesh of 250.000 vertices & 500.000 edges is an issue for armory (or maybe for our graphic cards :wink: )
1 Like

Hi Petit, thanks for trying … I have tried different meshes with smaller amount of subdivisions and it works fine - even with some extreme upscales to 100x100km :star_struck:

So the problem is with the particular attached mesh being too detailed and reaching some armory limit. btw for me the mesh is fine in realtime window but the armory player does not take it (gtx1060 mobile, arch)

Remesh modifier I didnt stumbled upon yet, so i try to play with it how it works if i do very detailed mesh with a lot of edges and remesh it … Thanks for the usefull tips ! and have a nice day

You’re welcome ! Have a nice day