Linux and Gnome touchscreen- Two workarounds for better experience

  1. There is a bug in Gnome, which prevents the On-Screen keyboard from popping up when you tap into an edit field. Especially annoying when surfing. Workaround, slide from bottom to top to invoke the virtual keyboard (VK) manually. To get rid of it you tap on that little arrow on the lower left of the VK. On my convertible Laptop this only works when fully converted to tablet mode (screen full 360 degrees turned) and hence the physical keyboard is turned off. Else no VK when wiping.

  2. Another (bug or deterring feature?) one. On Firefox you can only scroll with the right sidebar, which is somewhat hard to invoke without unwillingly tapping on some (ad!) link. Solution or workaround. Install BRAVE browser and magically swiping the content works as a charm and as a bonus advertising telemetry is per default minimized.