No autocomplete in kode studio

Using latest 0.5 in blender 2.79, Kode studio doesn’t show code completion.

I have had some issues with autocomplete in Kode studio for Armory games. It has to do with the armory build directory being different than the Kha defaults. I have recently made and update to the VSCode Kha plugin that lets you set the build directory so that autocomplete does work for Armory games. You just have to set the kha.buildDir workspace setting to the Armory build dir containing the project-{platform}.hxml file ( I’m not 100% sure which dir that is in Armory 0.5. Probably something like build_project-name/debug. ).

I don’t know if that update has made it into KodeStudio or not, and I’m not 100% sure the change has made it to the VSCode Kha plugin on the VSCode Store yet. I might be looking into it more somewhat soon, but that is what I know at the moment. :slight_smile:

1 Like

Thanks for the reply. It now work, the problem was that kha and krom were pointed to wrong folder, it was pointed to folder that i deleted and didn’t exits.