Setup on Mac with some issues

Hi everyone,

I’ve started to test Armory but found some issues that I would like to share to see if you can help me.

Initially I just installed the Release SDK 0.6 but found that the Blender inside were presenting some issues like, the pointing selector on navigation tree wasn’t working, and launching the game inside blender were failing at least 90% of times. So I’ve decided to install the SDK from source and link it to my existent Blender 2.8 checkout, and Kode independently. That worked better but still have some issue, kinda of small but somehow relevant.

  • After create the project outline from “Code Editor”, changes to Traits from Kode that are assigned to Blender objects are not reflected, even if I try to “Refresh” Trait.

  • I am not able to run the player from Kode, I am actually not very sure how to do it right. I have the understanding that I just need to open the relevant folder from Kode and that no workspace file is involved. If I hit F5 from khafile.js I get “ReferenceError: Project is not defined”.
    And if I hit F5 from whichever file in the project, I select Krom but then nothing happend. Aside note… Kode is premanent showing “Haxe: Building Cache…” at the bottom.

  • Still some Krom player builds fail randomly without any logging.

I was able to compile now the game from Kode after linking Kha directory from armsdk to project directory. But now it fails with “Debug adapter process has terminated unexpectedly (exit code: 1)”, where I can see a verbose message of this log entry? Kode just popup that line.

Kode player build solved with this post: Armory editing in VS Code?