[SOLVED] armsdk 2022.8 for BlenderLTS 2.93

Hi i am a mac user i am new to armory 3D first off i like it but i have a problem with it krom is not working i follow the setup on Github and i also follow with the guy on youube on how to install armory 3D but krom doesn’t open when i what to test my (Test build game) i try doing a test export to see if it would work as well and it didn’t i try Krom and try C nothing but everything else was good
can everyone help me please

Hi and welcome to Armory3D.

To know more about why Krom is not opening, I would like to know if there were any errors during export or installation. To see error messages, start Blender from the terminal using /blender.app/Contents/MacOS/blender and run the game.

Please post the console output here so we can figure out what’s wrong.

hi thank you here it is Last login: Tue Aug 30 08:16:22 on ttys000

wadeburridge@wades-mbp ~ % /Applications/Blender.app/Contents/MacOS/Blender ; exit;

Read prefs: /Users/wadeburridge/Library/Application Support/Blender/2.93/config/userpref.blend

Running Armory SDK from /Users/wadeburridge/Documents/armsdk/

Proxy objects synchronized

Info: Total files 1 | Changed 1 | Failed 0

Armory v2022.8 ($Id: 64befe1a38bc79094f87f9f2b788677fc1e1a1d6 $)

Saved: ‘/Users/wadeburridge/Desktop/build_Test/compiled/Assets/envmaps/env_World.jpg’

Time: 00:00.09 (Saving: 00:00.01)

CMFT info: Converting latlong image to cubemap.

CMFT info: Saving spherical harmonics coefficients to /Users/wadeburridge/Desktop/build_Test/compiled/Assets/envmaps/env_World_irradiance.c

CMFT info: Done.

#512x256

#256x128

#128x64

#64x32

#32x16

#16x8

#8x4

#4x2

#2x1

#1x1

Exporting Scene

Scene exported in 0.004s

Finished in 8.577s

Thanks,

It’s interesting that there are no error messages, so everything should work normally.

What type of game are you running? Is it a default blender scene? If not try that, please.

Also, do you click the “play” button or the “export” button here? What happens if you click the play button?

i was just runing a default blender scene and i did click play thank you

So it works when you click the “play” button?

no it says it’s running but but i get no krom information to test game with

Hmm, interesting. Unfortunately, I do not have access to a MacOS machine to test. But I will try to ask around.

Also, what happens if you play on Browser? Does it work then?

thank you
yes it works in Browser

1 Like

I’m actually experiencing a similar problem. I decided to stop daydreaming about how cool Armory3D is and actually do something at all with it.
So, I did what OP did, but with Linux (Zorin OS Live Boot from USB), and got the same results. Nothing with Krom, something with browser (except no lighting).
Same SDK version (latest) and Blender LTS 2.93.10.

Errors

I do get some errors, but I haven’t yet figured out how to use the debug console to get them (it’s different than the Blender Console editor, right?).

On a related note, I thought that maybe installing VSCode would help, but I decided to do VSCodium, because Microsuck and telemetry. VSCodium was available in my Software package manager as a Flatpak, so I did that. Then I realized I have no idea how the hell to find the “executable” location to get Blender/Armory to point to it in the “Advanced” settings under the add-on.

If all that is unnecessary to get this to work, then awesome (though, I’d still love for it to be easier for a newbie to figure out basic stuff like this in Linux without going to a support forum).

What GFX cards are you guys using? Also check that the pre-compiled Krom executable is in ArmorySDK2208/Krom/Krom.app/Contents/MacOS/ respectively ArmorySDK2208/Krom/ for Linux. For Mack verify your Java version installed as Krom is Java based there. There might be some weird thing wrong with your setup, as i have Krom running without problems on Manjaro/Arch Linux.

Please specify, especially “no lighting”. What do you mean?

Did you follow this guide here: Installation

Sorry for responding late. Had IRL and technical issues come up.
So, by “no lighting” I mean that the cube looks like this:

However, when I updated to the latest SDK and stable Blender version, that seems to have been (more or less) fixed:

Yes, I did follow the install instructions. My GFX card is GTX 1050 Ti. I looked and it seems the executable is there:

I also get this whenever I try to compile for either Krom or Browser and I don’t know which console it wants me to open: Screenshot from 2022-10-02 11-50-23

Hi, on Linux or MacOS you need to run Blender from the terminal in order to see the console output

1 Like

Alright, finally learned how to do that (using ./blender is not an intuitive command). It’s the same issue that others have been having with X11 and the “missing dependencies.” I’ll try the suggestions for that and report if it worked.

Side question: about using VSCodium instead of VSCode, is it possible to use it as a flatpak with Blender/Armory? I’m not sure how to find its executable to point Armory to, so I might need to install it as a .deb package or something to do that.