Banding and artifacts on test scenes


#1

Browsing around github and decided to test some scenes, found out there’s this weird banding that comes up on my computer. Using a 1070 on a laptop with windows 10, Krom target v0.2 . Can someone throw me a bone on how can I make the scenes non artifacty ?


#2

I’m not sure, but sometimes adjusting the bias value of lights seem to help against that kind of artifacts, at least the only thing I can think of


#3

Thanks @Naxela, playing with the value partially fixes the banding depending on object angle, the floor for some reason still gets some light banding effect at some angles but only at camera close range.
Splotches on the wall disappeared.

Though just noticed were walls intercept there’s always light spill no matter how the values get tweaked. So it is probably other factor playing to that. Weird because on the right side the ceiling and wall are the same object.

The saw pattern on some shadows maybe related to something other too. Do you happen to know ?


#4

Looks like a too high/low shadow bias value. (Though admittedly that’s just a guess based on experiences with other engines.) May be check your lights :slight_smile:


#5

I did like previously stated. There’s one light. The way it came from github produces the images on the first post.
With light bias adjustment could get rid of most of the artifacts, still there’s no “good” value that makes corners not leak light and that shadow by the bed look like it should.
It didn’t look like the provided image when downloaded from the github example and am not being able to reproduce that “clean” shot.

The light leaking in between walls is the weirdest now. Maybe it’s just the state of dev at this point.

https://github.com/armory3d/archviz_templates/blob/master/img3.jpg


#6

@Xico

Good to hear the bias solved some of the problems. As for the actual light leaks in the corners, I think they’re caused by GI light leaking, which I presume is caused by either the current Voxel GI only bouncing once, or the fact that the actual GI voxels presumably are too big for smaller leakage areas such as the ones you show. I guess in the future the Voxel GI stuff could have some kind of adaptive thing, but I’m not really that much into that, I guess it’s more Lubos’s area.

A way to circumvent the problem is possibly adding shadowing buffer meshes (or something, I’m not sure what to call them). Basically, it’s a sufficiently large box that shadows from the opposing side, like in the pictures below:

As for GI settings I think could be relevant might be the GI Step and GI Range, but I’m not exactly certain of the effects.

As for the saw pattern, my guess would be that either a bigger shadowmap (try 4K, 8K or 16K), or perhaps something with cascades not yet being supported by Voxel GI, or finally maybe it could be solved with soft shadows, although It’s just what I can think of the top of my head


#7

I read somewhere in an answer to an bug report on github that shadow-cascades do not work with GI, so they are disabled.


#8

@Naxela , the large obstructive solid out of sight thing, got to try that. Thanks.