Disable mipmap


I was wondering if it’s possible to disable mipmaps on either the whole scene or specific elements?

I tried looking into the manual, although the closest thing I could find was the kha enumeration kha.graphics4.MipMapFilter - would it somehow be possible to apply the NoMipFilter value to specific objects or textures somehow?


Yes, there is a way if you set Anisotropic Filtering in Properties - Camera Data - Armory Render Props to Off. That way a plain linear filter will be used and no mip-maps generated.

If set to Auto, it tries to match interpolation set in Image Texture node.

(Will turn it into more obvious ‘Texture Filtering’ option in next build…)


Thanks Lubos, working perfectly!