How do you use enviorement maps?

question
#1

I’m using a .hdri image on a background node for my world material, it works well in bender, but I can’t launch the player, neither in krom or browser, this traceback pops out:

The problem persist with images in other formats, regardless of size. What do I have to do to get this to work?

0 Likes

#2

pQGUNgGm5qdMZd.png)
Like this:

Edit: sorry, i must have posted this by mistake

0 Likes

#3

Your attached image doesn’t seem to show - Anyway, environment maps works on my end. You might want to try simplifying the path, spaces (such as the one between “Armory Projects” and underscores sometimes causes problems - You’ve tried other HDR maps?

0 Likes

#4

Yes, I tried different images from various sizes and formats, always yielding the same result.
I tried getting rid of spaces and underscores, but the problem persists.
Thanks for your attention.

0 Likes

#5

Does it still provide an error message if you turn off both radiance and irradiance probes? - Also, I notice you’re using version 0.6, I take it that it’s the itch version without any git updates?

1 Like

#6

Turning off those probes solves the problem, thanks.
Indeed, I haven’t updated my version of .6.

0 Likes

#7

Good to hear you solved the problem,
While it does take a bit of the realism off (the probes adds a nice effects from the environment map), but as long as it works - I think the bug was solved a little after the 0.6 release

1 Like

#8

Hmm, I’ve been putting off updating armory, and now i don’t remember where it was explained how to update it, do I need to use an updater or just clone the current armory version from github?

0 Likes