3D Mouse Spacenav

Hey guys. I understand that Armory 0.4 with Blender 2.8 is for testing purposes at this point. I was testing a 3Dconnexion 3D Mouse known as a SpaceNavigator® for Notebooks on a macbook. These worked great in blender in the past.

Post to installing 3DxWare drivers my Armory build crashes as soon as I attempt to use the device. Is there way to get logs or turn on debugging so I can see what is going on?

Hello! Is everything fine in standard Blender 2.8 build? ie only the Armory one is crashing? Are you able to start it from terminal and see any crash log there?

Hello lubos. I don’t have a vanilla Blender 2.8 installed to compare with however when I run the Armory_03_mac.zip which has Blender 2.7 prepackaged the 3d mouse works fine. I may try to upgrade the armory sdk next as another test when I get the chance later. The download page doesn’t say much about light packages but mac only has 3 binary options that I can see atm.

Below is output of working Blender 2.7 with Armory 0.3 from Armory_03_mac.zip
Toms-MacBook-Pro:test2 Tom$ cd Armory/blender.app/Contents/MacOS
Toms-MacBook-Pro:MacOS Tom$ ./blender
Read prefs: /Users/Tom/Library/Application Support/Blender/2.79/config/userpref.blend
found bundled python: /Users/Tom/test2/Armory/blender.app/Contents/Resources/2.79/python

ndof: using SpaceNavigator

Blender quit

Below is failed output for Blender 2.8 with Armory 0.4 from Armory_04_mac_b28.zip
Toms-MacBook-Pro:MacOS Tom$ pwd
Toms-MacBook-Pro:MacOS Tom$ ./blender
Read prefs: /Users/Tom/Library/Application Support/Blender/2.80/config/userpref.blend
found bundled python: /Users/Tom/Armory/blender.app/Contents/Resources/2.80/python

(plug in 3d mouse)
ndof: using SpaceNavigator

(Still running - Crash upon using mouse)
Writing: /tmp/blender.crash.txt
Segmentation fault: 11

Toms-MacBook-Pro:MacOS Tom$ cat /tmp/blender.crash.txt
# Blender 2.80 (sub 15), Commit date: 2018-05-28 01:30, Hash ed1e166

# backtrace
0   blender                             0x0000000101fd8f47 BLI_system_backtrace + 55
1   blender                             0x0000000101553c7b sig_handle_crash + 363
2   libsystem_platform.dylib            0x00007fff97e85b3a _sigtramp + 26
3   libsystem_malloc.dylib              0x00007fff97e100d5 free_tiny + 671
4   blender                             0x0000000101642643 ndof_orbit_zoom_invoke + 931
5   blender                             0x000000010155d5a6 wm_operator_invoke + 710
6   blender                             0x000000010155ec76 wm_handler_operator_call + 630
7   blender                             0x000000010155ddb8 wm_handlers_do_intern + 648
8   blender                             0x000000010155a43c wm_handlers_do + 28
9   blender                             0x0000000101559fc6 wm_event_do_handlers + 2598
10  blender                             0x0000000101554910 WM_main + 32
11  blender                             0x0000000101550761 main + 929
12  libdyld.dylib                       0x00007fff97c76235 start + 1
13  ???                                 0x0000000000000001 0x0 + 1

It may be a Blender 2.8 issue for MacOS. I have not tested in windows. I reported the bug on blender.

Note the 3D Mouse still works fine for Blender 2.7 when upgrading the SDK to Armory 0.4 via Add-On. The 3DxWare 10.5.2 mac drivers were also installed.

It appears the issue was fixed in a recent Blender 2.8 build? Tested on Hash d44c40d91c3 without crashing.

If I use the latest blender build is it fairly straight forward to add Armory to vanilla blender 2.8? Note they restored the TAB key with Object / Edit modes and replaced spacebar with the ~` key. Note if you hold TAB and move the mouse you can pick any mode.