Addon doesnt work

I did everything in the instructions, armory is in my addons, its enabled but still doest work. I restarted blender a couple of times still, doesnt work. Please help me

Ok, to help you we need some more information:

Did you set up the armory SDK?
Where did you get the armory SDK from?
Did you point to the SDK in the addon page in “SDK Path”?
Where did you get the armory addon file? ( or github)
What is your OS?

also your addon page should look similar to this:

And most importantly, what blender version are you using, because blender 2.81 doesn’t work.

1 Like
  1. Yes
  4. Windows

I am using Blender 2.8

Can you open the system console (by Window -> Toggle system console) and see if there is any error appearing there?

There is nothing when i open the system console

Ok, Do you have git installed? maybe there is an issue that’s been solved in the latest version of SDK.

If you do, click on Update SDK and wait for the update to finish, you can check in the system console to verify the process.
If you haven’t git installed, remember to close and reopen Blender when installing it.

I do have git, and I did update it but it still doesn’t work.

Something I forgot to ask, what do you mean by “it doesn’t work”? Armory UI stuff in Blender does not show at all? or something else doesn’t work?

Armory shows up in the addons but it doesnt show up in the ui.

Can someone help please

Does SDK Path meet the following conditions?
When naming folders/files, prefer unaccented alphabetical letters A-Z .

What about clicking the Restore SDK button?

How about removing armory from blender once and deleting ArmorySDK folder, then unzipping the zip file again and installing it?

If you attach the “Blender Preferences” and “system console” images, the cause may be easy to understand.

Assuming this is your bug report?

See if this helps any.