Animation doesn't work: What am I doing wrong?

I’ve spent a bunch of time trying to figure out just what’s going on with the animation system here, and basically given up.

The source model is included for convenience in debugging.

What I’ve done:

  • Appended the model to the scene (Linking seems to detach the model from it’s armature for some reason??)
  • Added a trait which dumps the action list, confirming the requested action does indeed exist in the model
  • Plays an action
  • responds in the console that it’s finished playing the animation (it loops so this just happens every second or so)

What happens:
The model shows up (Half of it is missing, likely due to ), and the callback fires, but the model itself is static.

I’ve verified the actions still play fine in blender. I’ve also tried baking the mirror modifier to reduce the number of variables, but that doesn’t change anything.

Bumping this. It’s a show stopper for me right now and none of the hacky workarounds I’ve tried have had any success. I feel like I’m fundamentally missing something on how armory’s animation system works.

If I select Idle in action editor with armature selected (so there is some default), the animation plays. But that sounds like a bug, looking into it.