ArmorPaint 0.6 Development Builds Out!

To quote @lubos from Twitter:

New ArmorPaint development builds are now up if you feel adventurous, approaching 0.6 release!🎨

NOTE: These are development builds. Not final. Not beta. Not even alpha. Caveat emptor!


Hi, is it working under armory 0.6 and blender 2.8?

It’s a standalone application. It uses parts of Armory3D under the hood, but ultimately you use ArmorPaint to texture the models, which you’ll then afterwards open in Armory3D to turn into a game.

1 Like

I opened armorpaint.blend file, set api to open Gl and when I Run F5 this error pop up.

Downloaded the windows binary,
good news: no more black spots while painting.
bad news: text rendering is all wrong.

Also it crashes when I minimize it.

Workaround for the text bug, if you scale the ui to more than 1 it works. Finally I can use it!


You will need to update armory to latest git version

I checked it just now and it is fixed in latest git :+1:

1 Like

@RazorbackDB do you always get that ugly font with ui scale set to 1? :thinking: As soon as you set it to 1.01 it’s fine or do you need to go higher?

(Also updated windows build with a fix for the minimize crash.)

No, it seems to get fixed at 1.2>



Also if I zoom out far enough in the node editor same bug happens

Minize is fixed like you said. This is all on a Ryzen 2500u (Vega 8) with latest drivers. Sorry for not being more specific before and thank you!

Ok, Im starting to be a little bit nervous.
I downloaded:
-armor3d via
-armorpaint:cloned via Github
-in blender I Updated armory via Git
-open gl is set up
What Im doing wrong?

That process should be easier for new incomers.

*not cloned but downloaded, but nevermind, when I hit F5 this error occurs.

The Armory update that you did through the Blender interface may not be sufficient to get it up-to-date enough to run Armorpaint. I’m pretty sure that the Blender interface doesn’t update Kha.

I was able to run it with the latest git version of the Armory SDK. Try this doc.

It didn’t last time I checked a few days ago…

The updater is supposed to clone everything, including Kha and Krom from:

Not sure if something weird is going on there? Seemed to work ok so far.

For the issue @Veprovy_Narez has been facing, solution is here. :slight_smile:

1 Like

Oh, OK. Good to know, I don’t have confirmation that it didn’t work, I just couldn’t remember if there was something different about my pulling Kha master and the Armory updater from a while back, and I didn’t know there was an armory3d/Kha.

It works now.
Thanks Luboš.

1 Like

Hello! I payout armory Paint 0.5 and 0.6_dev! Can I help run armorypaint 0.6 appliation error message it is 0x000007b.
I need install redistVC 20xx version?

My config hp-z600 20gb ram and gpu0>gf960gtx gpu1>M4000 quadro gpu3>gf1060 os win7

Thx answer!

Hello! Can i help!

AP.06 used win7 but error message here fix 0xc000007b error. win 10 correct run no error message!
I can’t use home machine win 10 a love win 7! I happy if run .06 run win 7 :slight_smile: i need install more frameworks latest and visual c++ package install?


The “0xc000007b” is a quite generic windows error, and it doesn’t tell much - but try the following to see if it helps: