Armory addons on 2.80 dont work

I recently moved from Windows to Ubuntu, and since, i need a new copy of Armory3D. I paid a visit to and noticed that Armory wasn’t having 2.8 releases anymore. so I downloaded armory for 2.79, and downloaded blender 2.8, just to notice that Armory3D doesn’t load there, and I don’t want to use blender 2.8.
Any ideas?

Armory for 2.79 doesnt work for Blender 2.8
If you are using Blender 2.8, then get Armory from git

I want to use armory 5, not 6. is there any way?

then use Blender 2.79

I’m too used to blender 2.8 to downgrade. is there any way to build armory for 2.8?

There isn’t a way to build Armory for 2.8. If there isn’t a download of Armory 0.5 for Blender 2.8 then maybe Armory 0.5 was never ported to 2.8. If there was a version of Armory 0.5 that did run on 2.8 you would have to know the commit hash for that version of Armory in order to get it, and I don’t think that the commits for Armory releases are documented, unfortunately.

Your best bet if you want to use Blender 2.8 right now is to use Armory 0.6 Alpha, but you will have to deal more bugs and stuff.

This is the version you’ll have to use, from alpha 6 Armory should no more support Blender 2.79 to avoid double work, if i’m not mistaken.

0.5 was also ported to 2.8(2.8 alpha 2), well so i see that 0.5 for 2.8 is removed from
Yes, 0.6 will ONLY use 2.8 because handling 2 versions is too much works

1 Like

Thanks all for your help!
Would say i would like 2.7 with less bugs less than 2.8 without bugs, but that relies on the user.

1 Like