Armory error occured during compilation

I am trying to test Armory Engine, i followed the instructions to install it but after that when i press f5 or play i get this message “error occured during compilation”


I didnt add anything to the scene… since i am just trying to test and following tutorials to set everything

maybe it could be a silly mistake? i tried looking on internet but didnt find anything. could someone help?

Hello and welcome to the forum.

A few questions:

  1. What operating system are you using?

  2. If you clear your Armory project’s cache, do the errors still exist?

  3. If you disable all renderpath sections (shadows, voxel ao, world, postprocessing, compositing) + plus clear your Armory project’s cache, do the errors still exist?

    • If the errors no longer exist after executing this last experiment, could you please reenable, one at a time, the renderpath sections (while also clearing the cache each time) until you get any potential errors again, so that we can debug what is possibly causing the issues.
  1. I am using blender 3.6 build compatible with windows 7. i got it from github
  2. Yes i did try to clear and the error persist
  3. about render path it is located under Armory Project>Armory Render Path, right? i click on the down arrow but nothing shows there, its all empty… i didnt check it before. could it be the problem?

display the sections, but theres no options there, its absolute nothing

There is a fair chance that your windows 7 is causing the issues. I am not certain though.

like your version of Blender isn’t rendering the Armory UI properties correctly, which in turn, may be the logical cause of your Armory project errors. Could you please close Blender, then reopen it and report back with any errors you get when you reopen it.

I did it but i didnt get any error. just when i press play i get that message. i tried reinstalling blender and armory from zero with a new setup but same error


about the rendering path i am sorry i didnt see that i needed to add an option before getting the settings. i did add desktop and uncheck everything but got the same “1 error ocurred error occured during compilation”

wish i could test it on win10 but i am also afraid if i purchase and install and get the same error

Whow, wait a second. Armory is completely free. Where and why are you buying Armory? Or are you perhaps mistaking the voluntary donation UI at for purchasing UI?

1 Like

oh sorry i meant purchase win10 . i’ve choosen to keep my personal pc in win7 for a while

Could you please try enabling Verbose Output and reshare the console logs? If it’s easier, you can just copy-paste them here instead of taking screenshot(s).

1 Like

is it possible to copy from the console window? could you tell me how? yes it would much easier

Just hover over the console window and select the text from the console and copy the text using Ctrl+C to copy the selected content, and then move over here (the forum) and do Ctrl+V to paste the copied content here.

i tried it but it doesnt let me copy or select, only type. i cant scale the window also

Maybe try exiting Armory before you try to select/copy from the terminal? Are you sure the console is even active? (Just because you see it doesn’t mean the console window itself is active.) Make you sure click onto the console window itself to ensure it’s active.

i opened in windows > toggle system console. when i exit blender the windows close as well

I think you misunderstood. I didn’t say exit Blender: I said exit Armory.

I didnt understand. since armory is an addon of blender, how could i exit without closing blender?

This is what the Armory Play button looks like when Armory is inactive.

And this is what the button looks like when Armory is active. When Armory is active, click the button to stop Armory.

In any case, it appears you’re confused on what Armory is. Yes, Armory is a Blender add-on, but the add-on is just a plugin and not the engine itself: which Armory is. The add-on exports to Armory and runs the Armory engine externally. It runs in a separate window.

oh when i get the error it imediately stop. however i cant copy what says in system console, i looked online and found another thread the guy was having problems too and he took screenshots of it. i still dont know how to copy it