Basic ambient lighting is far to high after updating Manjaro Linux and Armory3D

Today i updated from the November release. Did renounce updating because of broken canvas feature. Now the canvas stuff is nicely fixed, but something destroyed the possibility to adjust the lighting to my personal artistic taste. There is a certain base ambiance brightness you can´t get rid off, i tinkered several hours. Switched everything possible on and off, no dice. In 2021/11 it was as easy as turning the Color space strength down in the world environment settings (either env map or sky texture activated). You could beautifully adjust any desired lighting atmosphere.
This is the very main feature for me which made me like armory so much.

Can anybody tell me how to get rid of that base ambiance brightness that no mouse has a chance to hide in that house. I am so much disappointed… I will revert to 21/11 again and be seriously demotivated to use Armory3D at all, until i find a solution. Maybe its a bug?

(using Manjaro Linux with AMD GFX)
Someone please help!


I’m not sure, but this PR might have caused the change.

Also, a small example blend file and a few images of how it looked in the 2021/11 and 2022/1 releases would be helpful.

Edit: Also, how about reducing the strength in the world shader or reducing the light intensity. Does that fix the issue?

1 Like

Of course not, as i said i tried several hours and i know this Blender tab like my pocket. I will check it out on Windows now, as it could also be the AMD driver update. I did update my LINUX system and Armory3d. Hold on…15 min.

If it’s an Armory issue then it’s indeed probably the pull request QuantumCoder linked above, however that PR should make things rather darker than brighter as the world was too bright before…

Does the problem persist if you turn off Armory Render Path > World > Irradiance?

1 Like

Tried that as well, did not change anything. BUT: I tried under windows AND no such problem at all. Armory3D looks beautiful as always and on a short look the same with 21/11 and 22/02 SDK. Ergo sum: Main suspect now: Manjaro update and AMD drivers, time to tinker :unamused: Should change the header of the thread starter…will try. Add info: Also tried SDK 20/11 again under Manjaro, this has the same problem now —> Evidence its Manjaro or AMD driver issue. Sorry for the fuzz.

1 Like