Best HTML5 Publish Settings?

I’m making a game called LightStrafe - Online but am having some issues. You see, I can get the game to run in the editor, Krom, and even the browser, but when I actually publish the game it does not work for some reason. I’ve tried uploading it to it’s very own domain even where it loads the index.html file and should be able to access all the others. Still, just a white screen. At this point I have absolutely no idea what to do. I feel like I must have my project settings wrong or something. I have tried it with all options enabled, all options disabled, default options, default options but without “minify js.” Has anyone gotten any HTML5 settings to work so far? I’m running 64 bit Armory v5 on Arch Linux.

Edit: It may be worth mentioning that I’m using the logic nodes pack with the camera and character controller nodes.

There is no need to edit html5 publish settings. You might probably trying to load code file(kha.js) from other webpage(gitlab), like you said in previous post, which doesn’t work that way.
Here try this,

  • don’t change a single settings in html file(clean build to get default settings).

  • just host it from index.html without changing anything.

  • Host it directly from folder where index.html is kept

Check out this->

and try to look at, its worth it. But if you still want to host game on you own web than it your wish.:smiley:

I know this is offtopic, but Screenshot%20from%202018-09-29%2011-22-29 might need to be fixed. Good luck anyways.

Are you sure you gave weebly all of your build files?

Screenshot%20from%202018-09-29%2011-34-00 kind of shows the issue. Maybe your Assets folder needs to be there? Put the entirety of ./build_(name) on weebly. (If you can, I’ve never used an external service for a website so I wouldn’t know.)

@Liverwurst Sorry about the naming! :laughing: Seems like I must have messed up my naming! :smiley: And I don’t have a favicon so that shouldn’t be an issue. Just need to make one is all. I have just been placing the “HTML5” folder into the site. So am I actually supposed to put all the build files in then? :open_mouth:

Also, if I just upload a default cube scene it loads. But when I upload my actual project it has the loading screen then nothing happens.

@Liverwurst I am getting a lot of errors in the console when I am on the game page ( ) and for the most part they are like this:


@TriVoxel You should post here that it works now, because others might be thinking about this.

@BlackGoku36 Was thinking the same thing actually! :wink:

So I found out what the issue was! I needed to put all the contents of the build folder into my domain. I was thinking that I only needed to place the contents of build/html5 into the server. Now it is working perfectly though! Also, to make sure that it will run properly I would first preview it in “Browser” mode from the “Armory Player” menu. That way you can properly troubleshoot it before fully publishing it. Now if you go to my website or the game it will play properly! Also, this was all because of the help of @BlackGoku36 and @Liverwurst :clap: :clap:

1 Like