Build12 environmentmap or reflection bug?

Just tested one of my model and it looks kinda wrong in Armory but it looked right in cycles but I think the reflection is off or wrong in Armory. I’m using ArmoryPBr and also test the principle shader in blender.

From substance painter what is the correct output for normal to use with armory ? DirectX or OpenGL ?

I already submited this Bug on github together with another issue that some reflections arent sharp enough

1 Like

The correct output for normal should be OpenGL.

Did this got fixed using Build 13? GitHub issue which seems to be related to this is closed. :slight_smile:

Yes it was @lubos :thumbsup:

1 Like

For me it still does not work correctly ? I tried build 13 and it still produced the same result. I also found another bug, when I tried to use environment texture, armory will comes up with bunch of errors.

I will email to you the models, textures and blend file. I use the Dining room exr environment texture from here

Oh, I am sorry I only tested if the scenery was lit up by the environement map, which now works again, but I forgot to test if metalics reflect it, which they dont I now know. To make matters worse I only tested with the Sky texture node so this error wouldnt pop up, which it now does when using a 360picture. Again, I am really sorry for not testing everything properly!

Thanks for sharing the files @tumira!

Found an awkward bug, space in .blend filename breaks the export of environment maps. After renaming “Portal Gun.blend” to “PortalGun.blend” and cleaning the project it seems to work for me.

Fixing it properly now so no renaming will be necessary…


I tried renaming the file to PortalGun.blend and delete the build files and cache files, it still display error on me when I tried to use the environment texture. Also can you look at the metal reflection ? Is it the same with cycles ? Cant test it on my end because it still display errors when using environment texture.

But without the environment texture and if i use the skytexture, the metal reflection is not correct as my first post. The cycles renderer is the same with substance, but with armory the metal reflection is kinda not the same.

You can see the at your picture the gun nozzle ? is kinda black with reflection , it should be silver with relection.

Also @lubos is it possible to use cuda for cycles rendering ? Is it purposely disabled for full ArmorySDK ?

If I use armory as addon I can enable cuda, but if I use the full blender files that comes from , cycles compute device will display “none” is it intended to be like this ?

Will check the metal reflection, may need some tweaking there as well. Weird that it still fails for you - can you get scene4 example to work?

For cuda compiling Blender needs additional setup, so that is the reason why it’s still missing. Would be cool to finally get that done though.

scene4 is running without errors. But the reflection is also not correct.


I dont think it is just me. @Simonrazer also said he has this error. He does not have the portal gun.blend file. So maybe the spacing on the filename is not the only one causes the error ?

Yup totally, there may be more issues which I am not triggering on my machine. Can you try to use the environment map from your portalgun in scene4? Have to figure out why the scene4 works for you while the other one does not. (Even though reflections are incorrect - will fix that in shader code). Thanks for your time!

(Edit: Maybe the location of portalgun.blend also contains some non-letter characters?)

Yeah, I think I found out the reasons. I put my blend file in this directory “D:\Armory Projects\Test 3”, when I change the directory to “D:\ArmoryProjects\Test3” it works. So not only the filename cannot have any space, the directory also need to remove the space characters.

Hope this is fix in the next release. Or maybe did a build13b release ?


1 Like

Should be fixed in git now, sorry for the trouble! Also fixed some more environment map lighting issues. New builds going out in upcoming week. :slight_smile:

I believe I have discovered what makes the reflection bug happen.
if you open any version of the blender other than the armory
something changes in the ‘temp’ folder
but you can use the armory in blender 2.70 and 2.8 that will not have problem
by the tests I did the bug is generated only if you use another blender with not have the armory, being 2.79 or 2.8
but if you have had the bug, just clean your user’s ‘temp’ folder.