Dds bug with Armory

Hi Everybody !
First of all, I would like to congratulate the Armory team for the great job they have done.
Today, I have tested to import a blender scene (a morrocan swimming pool), and the results sounds really good.

As you can see, I have 2 issues with the palmtree foliage.

  1. The transparency does not work whereas I have a dds file (which includes transparency), plugged in the ArmoryPBR shader.
  2. the mapping is inverted ! However, when I check in the Blender window, this is correct. The bug only appears in the armory engine…

Hope someone might help me


try to convert the .dds to something like portable net graphics?
then, try to set the normals manually instead of just using the integrated set normals feature.
and by the way…
that tree is coming straight from the ground, isn’t it?
maybe put a dirt pot thing under it?

About your second point:
Are you using the “Texture Coordinate” node then make sure you are using the latest armory version. There was a bug a while back that flipped the uvs in the y/v-axis but that should be fixed now.

If you are using an “Attribute” node instead then there is definitely still a bug in there. Just checked and the uvs are still flipped on that one.

EDIT: opened an issue about that on github ->

Hi all !
@Parsa_Shahzeidi: Concerning the pot, yes it exists, but I had some difficulties to show it into armory. I have found the reason today: multi-material mesh is not accepted. I have separated the mesh to become a mono-material mesh !
I have converted the dds files in .jpg, but I have still the issue:

Something is wrong with my shader, but I don’t know where…

@manfredp: yes I use the “Texture Coordinate”, but when I deactivate it, the texture is now normally applied ! So, I need to use the beta version (because I am currently using the Armory_04b_linux64_b27.7z…)

See you guys

Can’t see anything wrong with your setup either. Tried the same on my end and it works. If you want you can upload the blendfile and I’ll take a closer look.

I would always use the newest version of armory. Everyday I have time to play around in armory I do an update and use the latest version from github. Never had crashing problems in the last few month.

Hi manfredp !

Some news from here:

  1. with the armory beta version 0.5, the node “mapping” now works and the textures are correctly flipped.
  2. Even in the beta version, I have still the issue with the opacity shader. So, I let you a .blend file with 2 shaders: one with one dds file, and one with 2 jpg files (diffuse + opacity). Results are the same…
    By the way, attached files function does not work for new users ! :cry:

By the way, I use Ubuntu 18.04 64bit, on AMD Ryzen3 + Radeon Vega Graphics…with the Xorg drivers (not the AMD official drivers)

Topic closed !
I have forgotten to set “Translucency” to “On”, and to check “Discard” in the material panel…Now it works !

Now, a realtime render of the scene with armory ! Everything is now OK !

1 Like