Dying to get started, but Krom error/delay problem

Hi Folks,
I’ve installed latest 0.5 version and everything seemed to work (Win10, nvidia 1070, i5)
Following tutorials. But here’s the BIG problem. I can’t preview in Krom. When I hit F5, I get a white K screen window appears. Then it just hangs non-responsive. This is with just the cube.
If I wait like 2-4 minutes, it actually works, but that is far too slow for a preview.
It does work with Browser build, and I’ve been working with that. BUT, I can’t use Haxe then because Haxe builds/previews to Krom.
So this is really 2 questions:

  1. Krom hanging with white screen, eventually loads but too slow for any kind of work/preview
  2. How do I get Haxe to build to HTML5 instead of Krom?

Thanks and I hope somebody can answer one of the above. I am very excited to try this but without preview it’s of course impossible. Best to all.

Are you Building from blender? In Armory player under render tab?
Haxe build both HTML5 and Krom.
Do the folowing:

  1. Go to Armory player under render tab(As shown in image below).

  2. Then select Runtime as Krom and then click Play.

Toggle the console windows in blender.
Run the program and share the output. Also, Toggle your Armory Render option and share the screen shot of it.
Most of the time, information is in console output and some changes in render options are the culprits.

HI thanks for the response(s).
Here is the options expanded out, everything is just default:

Here’s the hanging white screen:

and the console output:

Read prefs: C:\Users\tcdoe\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
found bundled python: H:\Armory\2.79\python
measureit: Imported multifiles
archimesh: Imported multifiles
path not found
addon not found: ‘GearGenMaster’
path not found
Armory: Proxy objects synchronized
MeasureIt: Cleaning data

Armory v0.5 ($Id: 626ed79f35d8830a987f2794c95bac04c8934899 $)
OS: win, Target: krom, GAPI: opengl, Blender: 2.79 (sub 0)
Exporting Scene
Exporting mesh Cube
Scene built in 0.018001079559326172
Exported modules: [‘audio’]
Shader flags: [’_Irr’, ‘_EnvCol’, ‘_Deferred’, ‘_CSM’, ‘_SMAA’, ‘_SSAO’]
Running: [‘H:/Armory/armsdk//nodejs/node.exe’, ‘H:/Armory/armsdk//Kha/make’, ‘krom’, ‘-g’, ‘opengl’, ‘–shaderversion’, ‘330’, ‘–to’, ‘build_test08/debug’]
Using project from E:\Armory temp
Using Kha from H:\Armory\armsdk\Kha
Creating Kha project.
Exporting asset 1 of 1 (armdefault_data.arm).
Exporting asset 1 of 1 (shader_datas.arm).
Exporting asset 1 of 1 (Scene.arm).
Exporting asset 1 of 1 (World_irradiance.arm).
Exporting asset 1 of 1 (mesh_Cube.arm).
Exporting asset 1 of 1 (brdf.png).
Exporting asset 1 of 1 (noise8.png).
Exporting asset 1 of 1 (smaa_area.png).
Exporting asset 1 of 1 (smaa_search.png).
Compiling shader 1 of 1 (armdefault_mesh.frag.glsl).
Compiling shader 1 of 1 (armdefault_mesh.vert.glsl).
Compiling shader 1 of 1 (armdefault_shadowmap.frag.glsl).
Compiling shader 1 of 1 (armdefault_shadowmap.vert.glsl).
Compiling shader 1 of 1 (blur_edge_pass.frag.glsl).
Compiling shader 1 of 1 (compositor_pass.frag.glsl).
Compiling shader 1 of 1 (compositor_pass.vert.glsl).
Compiling shader 1 of 1 (deferred_indirect.frag.glsl).
Compiling shader 1 of 1 (deferred_indirect.vert.glsl).
Compiling shader 1 of 1 (deferred_light.frag.glsl).
Compiling shader 1 of 1 (deferred_light_quad.frag.glsl).
Compiling shader 1 of 1 (pass.vert.glsl).
Compiling shader 1 of 1 (pass_light_volume.vert.glsl).
Compiling shader 1 of 1 (pass_viewray.vert.glsl).
Compiling shader 1 of 1 (smaa_blend_weight.frag.glsl).
Compiling shader 1 of 1 (smaa_blend_weight.vert.glsl).
Compiling shader 1 of 1 (smaa_edge_detect.frag.glsl).
Compiling shader 1 of 1 (smaa_edge_detect.vert.glsl).
Compiling shader 1 of 1 (smaa_neighborhood_blend.frag.glsl).
Compiling shader 1 of 1 (smaa_neighborhood_blend.vert.glsl).
Compiling shader 1 of 1 (ssao_pass.frag.glsl).
Compiling shader 1 of 1 (world_pass.frag.glsl).
Compiling shader 1 of 1 (world_pass.vert.glsl).
Compiling shader 1 of 8 (painter-colored.frag.glsl).
Compiling shader 2 of 8 (painter-colored.vert.glsl).
Compiling shader 3 of 8 (painter-image.frag.glsl).
Compiling shader 4 of 8 (painter-image.vert.glsl).
Compiling shader 5 of 8 (painter-text.frag.glsl).
Compiling shader 6 of 8 (painter-text.vert.glsl).
Compiling shader 7 of 8 (painter-video.frag.glsl).
Compiling shader 8 of 8 (painter-video.vert.glsl).
Finished in 4.462069272994995

– at this point the white window appears. If I wait about 1-4 min (varies) then the gray cube appears.
thanks again.

Yes from default armory blender. I’ve attached more info as requested.

Your settings seems fine.And There is no error in console.
Can you share the blend?
Also, check if you are using GPU for cycles rendering or not.
Clean your Build Too. The Button right Next to “PLAY” button.

I found huge build time as I cranked up the amount of verts in the scene but never for a cube. Are there objects in the blender file that are large vertex objects. Even if not visible I thin the engine still tries to make them ready to go upon build. I could be completely wrong on this. Just going off my own experiences.

Is it default blender file loaded???
Or did u do someting??

thanks for all the help. Yes, I’ve attached the whole folder in this zip file.
I have default blender, except I’ve made the camera focus to 80mm and moved it away a bit. That’s all.
I’ve unchecked all other addons except for default blender. Restarted a couple times just to be sure.
There’s only the single cube, no other hidden objects, etc.
Can’t think of anything else to try. I guess I can try on my other computer/laptop, but I definitely have to have it run on my development machine. Speaking of that, here are the machine’s full specs:


link to zip file (sorry forgot couldn’t attach): https://drive.google.com/file/d/1u1WuTAyge6ysf2dauj4wH8niswECaTMw/view?usp=sharing

just checked your file. It works A ok.
nothing wrong was found in it.
I guess, system is over working on some other program, that’s why you are getting a lag.

BTW , nice specs. I am running on 8th Gen 8 GB with 2GB nvidia laptop and armory runs fine on it. the largest file i’ve tried with full rendering options in FirstPersonShooter.Blend and it took only 30 sec to render on first try.

Run perfectly fine on my end. Perhaps try reporting issue on Armory’s Github.

Thanks to all. Well I guess I can post on the Github.
This must be a solvable problem. The system is not ‘overworking’ on another program, I running from a clean boot just to be sure of that.

Does anyone have a solution to the second question? … how do I direct Haxe to build/compile to browser HTML5 instead of Krom? If I select ‘browser’ in the Blender addon it works, but Haxe (editor) always builds to Krom, which of course doesn’t work.
Sorry if this is a noob question. I’m pretty good with C# and python but have not used Haxe before.
Thanks again.

Even if Haxe editor always build to krom, building it is same as building it from blender, there is no difference.
And you said Browser works? and krom doesn’t work?

Not solved, see followup.

(not) SOLVED. I’ve edited this post 10-29, orig below.

(jeez finally!!) Thanks to everyone.
The problem appeared to be a conflict with the nvidia graphic driver, and the redistributable install. I uninstalled my 2017 redistributable, reinstalled latest nvidia driver, then reinstalled the 2017 redistributable.

Ok now it works and fast, almost immediate.
Thanks again for all the suggestions, they enabled me to narrow it down.
I don’t exactly know what the problem is/was, but at least this fixed it for me. Works now on my laptop too.
Excited to proceed.
I’ll be posting a couple other questions in new topics.
Very best to all.



After working successfully for about 2 hours (been busy with other things), suddenly Krom is back to super-slow play/preview.

It was working great. I was just adding some 3D models/assets and hitting ‘play’. Krom window pops up and previewed fast/instant.

NOW SUDDENLY – for no apparent reason, it is back to the old behavior with Krom white screen and delay of 2+ minutes before the cube appears.

I tried reinstalling nvidia drivers, rebooting clean, starting armory/blender fresh and saving a new project, switching to cycles and hit ‘play’. NO LUCK.

I have a screenshot will try to attach here.

I’m extremely disappointed that I can’t even preview. I’m pretty good at setting these things up, and I should be able to at least get some consistency.

There is nothing special about my machine. I5, 16G ram, nvidia 1070ti, ssd drive 512, 2tb Ddrive.
Any help is critical for me to move forward with Armory and much appreciated.

How? After working fine for several hours, can I be back to this same delay behavior?? It doesn’t make any sense. Is there some other issue? I’ve re-downloaded and unzipped Armory to my root C drive and tried again with project save in my Cdrive/armorytest . STILL the same Krom delay with just the default cube. Everything else is default (I did select GPU, no difference).

You said it worked on your laptop earlier, does it still work on there? That is really strange. It seems like it must have something to do with your Graphics card/driver. Have you tried doing a Browser or C++ build instead of using Krom. I’m sorry you are having such trouble. :confused:

1 Like