Environment Texure causes Problem


I am facing a problem from beginning on when using environment textures. And I know that this topic has been discussed quite a lot of times and i went through all of them. And most of the times the problem was solved by doing this and that.

Armory always throws this error message when pressing the play button:

It shows that radiance file of the hdr could not be found. And when checking the folder there is no such file. After reading all the topics it seems that cmft is maybe not working correctly.

I cleaned everything.
I already removed all empty spaces in the naming of the files and folders.
I checked the HDRI if #?radiance is shown in the header which is the case and also tried different once from several sites.
Also I tried a .blend file that was offered to me here in the forum, but it didn´t work either. Always with the same result.
I reinstalled Blender several times and also removed all additonal addons.
I also swapped the cmft.exe in the folder.
But nothing solves this problem.

I am using Armory3D 2021-2, Blender 2.83LTS, Windows10, RTX2080 Super

Hopefully anybody can otherwise I think this will be my breaking point with Armory3d


it’s a bit difficult to see what went wrong with the error message alone, Armory tries to rename a file that was generated with cmft that seemingly doesn’t exist.

If possible, can you upload a small example file? Also, are there any files in the /build_untitled/compiled/Assets/envmaps/ directory or is it just empty (after the failed builds)? What’s the name of the HDRI used?


thanks for the reply. The orignal name of the HDR was “spiaggia_di_mondello_4k” and I got it from HDRI Haven, I just renamed it to see if the name as a reason for this. The .blend file is the general starting file of Blender just with the environment texture added for test purposes. I am not sure if uploading this of any help. As I said a .blend file I received from here also throws the same error message.

Could it be something with the GPU, in other posts I read about GPU´s crashing cmft and then a new cmft version was set as standard, but that post was from something around 2017. I switched between cycles and eevee and cpu and gpu rendering. But i guess armory is not really bothering about this setting as it always behaves the same. Or is there some setting in the background that needs to be changed. In the mentioned post there were talks about a switch forcing cmft to cpu computing.

In thebuild folder there a only two files under assets/envmaps. These are test2_irradiance.arm and test2_radiance.hdr. But not the file armory is looking for.

Me again,
still not really sure what causes the problem. But I got my old pc out of its corner where Blender 2.81 ist installed and installed armory there as well. The same files do work there perfectly. Maybe it´s the GPU or some other hardware causing cmft to crash. Would be great if anybody could check this on their RTX2080Super.

That’s not correct indeed.

For me it also works just fine. What you can do to get more information is to enable Verbose Output under Render Properties > Armory Project > Flags. This will print the cmft output to the console which could give more information about what’s happening. Maybe a graphics driver up-/downgrade might help?

Other than that, you can setup cmft so that it uses the CPU, but this is much slower: Go to this line of code in your SDK folder and simply change gpu to cpu. Also, maybe change clVendor in the line above from anyGpuVendor to anyCpuVendor. Then restart Blender so that the changes take effect.

Some command line options for cmft can be found here.

1 Like

that the console output with Verbose activated. Cannot make much out of it but it seems yet only to process on the CPU.

I also did the recommended changes in the file. But the result does not change.
Any further suggestions?

Hi timodriaan,

thanks for your help. I got it working now. Overall it took month to come this far. Your hint to make changes to the “write_probes.py” did the trick. Your suggestions alone did not work but I also changed line 190 to cpu_count = 1. Now it works. Maybe the large amount of CPUs was the problem.

As already said thanks, great community!


That’s good to hear! May i ask how many CPU cores you have? I don’t think that cmft has limit for that, but it is weird somehow…

It´s a AMD Threadripper with 32 cores.