Errors using rigged and animated characters

Ok. I’m really trying to use Armory to make short animations.
The scene 3 example says you can use rigged and animated characters, and also provides Ballie model which is rigged and animated.

I have tried to import/produce my very own animated characters to render in Armory and it’s giving errors.
To try to identificate the error I have done several tests. Maybe someone can try to do the same and if manages to achieves results can say to me what I’m doing bad.

First example.
In a separate file, I have a model I work a lot of with.
It’s the Blenderella model you can obtain here

In this separate file I have created a simple Human Mega rig. This is an human rig who is generated automatically if you enable Rigify addon who is by default disabled in Blender.
I attached the human rig to Blenderella model. I produce a simple animation. (Only she moving the arm).

I append the file to a new scene created with Armory. (Remember to delete all the materials Blenderella has, since can cause conflict with Armory’s material system. If I try to render the animation, Armory crashes to desktop.
If I do the process openin Armory through cmd, the console log says this:

Second example:
Since I think It can have some problem with the appending, I created a new scene.
I append just the Blenderella model. (I delete all the Blenderella materials).
Blenderella model alone renders ok.
I create a Human Meta rig in this new scene. I attach the bones with automatic wheghts.
I try to make an animation. Same error.

Third example:
The same as previous but pressing the ‘generate’ button inside armature options to use the advanced bones.
Attached again with automatic wheights. Same error.

Fourht example:
I created a meta rig wihout Blenderella model. Obviously bones doesnt render. But I managed to make a simple animation and Armory did not crashed.

Fifth example:
I forget all about Blenderella and human Metarig, and returned to the Ballie model.
I deleted all the keyframes, and created new keyframes for the ‘walk’ action.
Renders the original walk action. Not the one I created.

I can record videos to demonstrate if someone ask me to do it.

Until someone doesn’t explain to me what I’m doing bad in this or the examples in the other topic, I think we won’t be able even to produce simple machinima with Armory.

As a final test, I wanted to know if the issue is related to armature’s hierarchies, and I made a simple
test with a simple cube and a bone, like this

No matter which option I use to attach the polygons to the bone. I’ve tried them all.
At the moment I give 1 single keyframe and try to render, it crashes to desktop.
At certain point I also believed it was related with the ‘automatic weighs’ option, but none of the other options worked.

At this moment I can say I dont know what kind of magic was used to rig and animate the Ballie model.

Hi Jose,

I did a small test with two bones and I’m having the same problem than you.

The main problem seems to be that the engine is expecting to load a file with the animation that is not generated.

In my case:

By the way, I also find two lines that could be related with the problem that don’t appear in your log. Maybe I did something different and these lines are only part of my problem:

Uniform skinBones not found.
Uniform skinBones not found.
Could not open file /Users/artur/Documents/Graphics/Projects/Tests/build/krom/bones_Armature_Bend.arm.

I will continue looking for differences with scene3.blend (provided as example) to see If I can find the issue.


Hello. Might all of you want to know.
I was really really curious about the reason for the Ballie Model not having any issue and the ones made by me were, so I founded and downloaded the original Ballie model from Blendswap.

I have discovered this model comes with 2 animations. 1 for walk. 1 for run.
If we try to render the running animation in Armory, it gets stucked. (also, the Ballie mode seems to include some kind of rare bug, because if we play the running animation, plays ok, then if we play walking animation, plays ok, then if we try to play running animation again, it doesnt work) Anyways. If we try to render with armory the running animation in the first place, happens that freezes completly.

Also, if in the Ballie model we delete the bone parenting, and we attach the model to the bones again(the exact model, to the exact bones) again, with control + P (with automatic wheights or a different option). Armory will render a deformed mesh. (but at least dont crash)

This is only confirming me that the engine has some kind of bug which makes animation not possible at the moment.
I hope this get fixed soon.