Footsteps and object outline possible?

This edit is for whoever felt the need to flag.

Regarding footsteps, it should be possible to place decals when moving on the ground when walking. Here a little .blend.
foot.blend (700.5 KB)(you need to get your own texture, it won’t let me upload mine)
But it only should, because it seems like there is a bug that causes the decals to spawn in the same place everytime instead if on the floor. Try it out by using the red sphere/turning of “decal” in the planes material-settings. Reported the bug on github.
Idk about outlining stuff, you can probably do that with some extras to the render driver.

1 Like

These would be nice addition to the examples if it’s possible. I haven’t played with your blend ,but it would have to switch between left and right foot textures.

definitely possible by using the “alternate” node and using two different spawn nodes.

I see my original post got flagged, lol. Guess your not suppose to mention other game engines or wonder if something is possible.

The only reason why I think it could get flagged is that those models weren’t yours. I didn’t look at them so I don’t know. And the only persons who are able to “insta-kill” a post by flagging at are lubos and xananax, or a lot of people flagged it so it got deleted automatically. I didn’t see anything wrong with your post.

Looks like it got flagged multiple times or somebody flagged multiple times. I see I got 5 flagging messages. I guess it fell under the “ links to” under the post only your stuff. Looks like a pretty policed forum, lol.

Actually appeares to be anything with links. I see some of my other post that I included to armory github links got flagged.

Just checked through your posts, and it actually does seem like the forum software have decided to flag all your link stuff, even throughout your older posts - it seems quite odd

Hi Simonrazer,
I started playing with Armory recently and
I tried your blender file for the footsteps.
It does not seem to work on the lastest Armory Built that uses the official Blender 2.8 release.

it seems like a Shader compilation problem, when trying to render the scene I have the following error, did you succeed to run your file with the latest SDK ?

Do you know how I can correct your file?
I am trying to add some footsteps for a simple test demo.

Many thanks

Compiling shader 1 of 23 (Material_001_mesh.frag.glsl).
Compiling shader 2 of 23 (Material_002_decal.frag.glsl).
Compiling shader 3 of 23 (Material_002_decal.vert.glsl).
Compiling shader 4 of 23 (Material_003_mesh.frag.glsl).
ERROR: C:\foot\build_foot\compiled\Shaders\Material_002_decal.vert.glsl:11: ‘spos’ : undeclared identifier
ERROR: C:\foot\build_foot\compiled\Shaders\Material_002_decal.vert.glsl:11: ‘=’ : cannot convert from ’ temp 4-component vector of float’ to ’ temp 3-component vector of float’
ERROR: C:\foot\build_foot\compiled\Shaders\Material_002_decal.vert.glsl:11: ‘’ : compilation terminated
ERROR: 3 compilation errors. No code generated.

SPIR-V is not generated for failed compile or link

Compiling shader 3 of 23 (Material_002_decal.vert.glsl) failed:
Shader compiler error.
(node:2412) UnhandledPromiseRejectionWarning: Shader compiler error.
(node:2412) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
(node:2412) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
ERROR: C:\foot\build_foot\compiled\Shaders\Material_002_decal.frag.glsl:40: ‘ImageTexture_001_store’ : redefinition
ERROR: C:\foot\build_foot\compiled\Shaders\Material_002_decal.frag.glsl:40: ‘’ : compilation terminated
ERROR: 2 compilation errors. No code generated.

SPIR-V is not generated for failed compile or link

Hm, I can’t replicate your error, but maybe try replacing the Armory PBR node with the principled shader node. Also I noticed the logic trait is not selected in the cube’s Trait slot, and in the spawn object node in the trait itself the plane with the texture is not selected. So you have to fix that as well, but that should not cause this error. Maybe some stuff got borked with the new Armory version and so these settings got deleted.

thank you Simonrazer,
I found the reason for the compilation error : having the Normal Map activated on the Armory PBR shader is causing the problem, so I cannot have an Armory PBR shader with normal map working at all.

Using the Principled BSDF fixed it.
Maybe it is due to my setup? I’m testing it on an low end intel graphic card as I’m interested in mobile.
The file is compiling but it is pretty static apart from moving the camera.
I’m not very familiar with the nodes logic but something should move and leave footsteps behind right? I look into the nodes and some parameters seems empty, am I right ?

Only the very last “Spawn Object” node needs the plane with the footstep material on it selected, which is currently not the case. All other empty slots are being filled in automatically as the object on which you use this node tree.

that’s what I though…and it did not work, so I am wondering if something is wrong with the last version of Armory?

Are you able to run the file on the latest build ? Are the nodes working?
foot2_Principled_BSDF.blend (598.1 KB)

Blender 2.80 (sub 75), branch: official master, commit date: 2019-07-29 14:47
Armory version :

DecalsNormal DecalsStain0006_1_600

You did not assign the node tree to the cube.

Otherwise everything is totally fine for me

thank you, it works on mine now.
I will continue digging the strange behaviour of the ArmoryPBR + NormalMap.

Many thanks for helping.