Gamepad Coords Node: Right Stick not working on linux?

Hi, I’m on linux mint 21.3 using blender 3.6.9 with armory 2024.01.
I’m pretty new to armory 3d after playing around with UPBGE. I’m slowly getting used to it, however there seems to be a problem with the mapping of the right Stick of my connected PS4/Xbox One gampad (both wired via usb).

For notice - I’m trying to rotate a a tank’s turret using the right stick which doesn’t work. Using the left stick works as expected… Is this a bug?

I found an Issue on github (#1717) that describes the problem quite fittingly. It is from 2020 tho… Gamepads right stick not working in linux · Issue #1717 · armory3d/armory · GitHub

I checked the haxe-script of the node in armssdk but everything seems fine.
Right stick coordinates are mapped to rightStick.x and rightStick.y… so it’s propably something underneath…

Assuming this IS a bug, is there a workaround? Not having a right stick is a bit of a showstopper =(

Thanks in advance!

Hi, trickster
I’m not an expert here but there’s my quick workaround (PS4):

  1. From the Software Manager install jstest-gtk, then run it.

  2. On the main window select your controller, then click on Properties

  3. On the new window there are your inputs and sticks value, go and click on Mapping

  4. Here you can drag and drop Axis to changes their order, move ABS_Z and ABS_RZ to the bottom of the list.

  5. Your axis beeing remapped, Armory should work fine now.
    however thoses changes are not permanent, and must be re-applied each time you unplug your controller or restart your computer.

There should be a way to make it persistent though I’ve never tried…

Another solution would be to edit the iron/Sources/iron/system/Input.hx file and modify the axisListener function to remap axis’s order in armory.

However, when I tried it my axis were flipped, and I could’nt figure why…

I hope it helped.