Glitches i've encountered

Here is a list of glitches:

  1. When i open armory from “Armory_version/armory/blender” i cant seem to find the armory nodes. Like “armory pbr”, and there is no logic category. . But if i open armory from scene 1 example then i can find all the armory nodes. This issue was solved

  2. When i play an armory3D game in blender, the mouse is visible and to actually look around i have to hover over the 3d view and hold down left click. (which also means that left click doesnt work ingame, so i cant shoot in the first person example)

  3. Anther thing when playing an armory3D game in blender, is that whenever i click space, this search window pops up. As if armory3d wasnt running a game.

  4. When i run the game as Krom i can actually use spacebar, but then when i jump i fly far far far in the air.

  5. In the first person example i can turn around comepletely, like im doing a flip. (It is also like that for every example where i can turn the camera)

  6. Instead of the teapot scene looking like this:
    It looks like this:

Also, something i would like seeing in armory3D:
Being able to also use logic bricks and not only logic nodes.
And having premade objects you could easily spawn into your project

Sorry for my english, not my native.

And i know armory3D is in very early development, and thats why i posted this

1 Like

pal, you need to add a node group to put logic nodes.

how? whenever i try to make a group nothing happens, and if i actually manage to make a group, the logic nodes aint there. i know how to add nodes, i just cant find logic nodes. send screenshots if you can

Edit: facepalm stupid me, i figured it out