[Help] Cannot Play in Viewport

Hi all, I just tried Armory for the first time, and got a problem: Whenever I try to “Play in Viewport”, either blender will crash, or the progress bar will stop at 50%.

However, I can play with the stand alone player with no problem:

Could anyone suggest what caused this problem? Thanks!
Platform: Windows 10
CPU: 6700K


have you tried to clean the project?


Hey Milo,

Thanks for report. There seems to be an issue with Play in Viewport using the newer nvidia cards. At least that’s my assumption so far, basing on similar reports at GitHub.

I went as far and ordered gtx 1060 just to get this sorted, the card should arrive tomorrow. Will report my findings. :slight_smile:

Hi Lubos,

Wow that’s a quick reply! Thank you, and I will wait for your good news.

@AndreaMonzini, I just tried to clean project, unfortunately it didn’t solve the problem.

Just a quick update - I managed to reproduce and fix the crash! Will package new builds soon - some more info here.

Awesome, i’ve got the same issue ! glad it’s fixed !

i have the same issue with the add on setup. i can’t run the player in blender viewport.
I have another issue, the regular setup doesn’t work for me.
My config : windows 10, AMD FX 8320E, GTX 1070 and 16go ram.

I have a question too, at this time can we navigate with the mouse in the armory viewport ??

Thanks, regards.

Ok mouse navigation is working, sorry …

Hi Lubos,

I tested with the new build and can confirm that the problem is fixed, Thanks!

1 Like