How to set an other world background than Sky Texture?

Which settings are needed to get own world textures working. I tried different images and generated patterns like voronoi, checkerboard. Also when simple setting a color it does not work as expected. The only world background that actually work for me is the Sky Texture.

In Eevee and cycles all my other textures and also patterns or colors works as expected, but in Armory player (Krom and Broser) nothing than Sky Texture works.

Is this a bug or missed I some settings?

I know you need to use an .HDR image along with an Environment Texture Node in shader editor / world node graph to get metallic surfaces to appear, metallic.

I’m not sure if adjusting the color value within the node would change the world color while running Krom though.

1 Like

Ah, the Sky Texture is a special HDR image, and only such HDR images work as world background?

But why are in your example only the reflections in the sphere visible, but the image in background not?

It displays on compile but I don’t think it was ever visible in viewport.

Tomte: Did you figure this out? I have the same problem and have not gotten an HDR texture to work with Armory on the Mac. Display of any HDR has worked before with the .6 Armory that worked with the Feb 20 amalgamated download (blender + Armory). Now (with RC3) it no longer works - did you figure out how a work around?


This works for me:

Hi M_Ent8h:

I have the world settings working exactly like you have it - quite fine, indeed. Did you get Armory to render that world HDR. That is my problem, if I run Armory, an error is given that seems to point to a process error with kaffiti - in write_probes. It might be fine on a PC. If that is the case I’d like to know about it since I’m running on a Mac.


Yes I am running Ubuntu and for me it’s working, so I guess it might be as you say a platform specific issue.

just in case though, are you using the latest version of Armory SDK? …If you are I would recommend opening an issue in the github repo with logs and details of the problem.

Yes, I’ve been using the armsdk from github and installing with new versions of Blender as they come out. I’ve posted details of the problem in git but have not received any replies there…probably a platform specific issue… I don’t think Mac gets as much attention as other platforms…