Is anyone else having issues with UV maps

I have a major issue with my objects that are UV mapped with textures.

the first pic is the object rendered in cycles and the second what I get in the game engine. It looks like it is rotating the uv map somehow.

Any Ideas or suggestions?

Update: tested in the 2.8 version with armory render engine and have the same issue with play in view port and krom.

Seems odd, it’s only a shot in the dark, but have you tried applying scale and rotation? I find that it’s often helpful for various uv related issues

Yep the object has applied scale and rotation. It is happening with any object with image textures, on 2 diffferent computers and in 2.79 and 2.8 versions of Armory.

What’s the material setup? Perhaps you’re using an unsupported/flakey node. I know I’ve run into that quite a few times now.

Pretty much a standard principled shader setup. here it is

Tried this with the armory PBR also. It seems that for some reason it is ignoring the actual UV’s and using the whole texture somehow. I also had the same issue with the using other objects and texture maps.

Any chance to see the .blend file so I can reproduce and fix it?

Sorry actually I fixed this by removing the mapping node. My understanding from others is that the mapping node has issues. I used a standard substance pbr output for the textures. if you still want a blend let me know - its on a different computer.

1 Like

Hm, will check out the mapping node. Thought that node setup like that should be fine.

1 Like

I have an issue with following the 1st example of tiling floor with checkerboard image. The textureImage stretches the entire length of the floor instead of repeating. It shows in 3d view port the image tiling correctly but not when I hit play. I’ve tried changing many parameters with no effect.

In the Playground Tutorial under Materials section. They should detail the settings for tiling textures better. The Vector / UVmap didn’t work for me.

This seemed to work for me.

My testing would suggest the bug is in the “Texture Coordinate” node and not the “Mapping” node.

flippedUV.blend (2.0 MB)

Thanks @manfredp, should be now fixed in git.


@lubos just realised the same flip happens when an “Attribute” node is used instead of “Texture Coordinate”