Kode studio not function

When i want to edit Armory Traits with Kode, when i press Edit Script it doesn’t happen nothing, i still waiting, but nothing happened, install haxe and haxedevelop, but i have the same problem, any solution?


Which Armory version and OS are you using? Can you spot any errors in the system console after clicking the Edit Script button?

If creating a new trait from scratch, maybe the New Script button was not able to create the script file because of permission issues?

If everything fails, are you able to run Kode Studio if you download it manually from here?

1 Like

@adrianolah182 have you recently renamed your armory folder or moved it to a different folder?

If so, and assuming that you use windows (although it probably also affects linux/osx on it’s own way), then the problem comes from the symbolic links created when you tried to open/edit a source file from the old location, since those symbolic links were created relative to the old location. If you go to:


and delete the symbolic links you’ll find to Kha and Krom folders, then the next time you try to open a
source file, it will recreate those symbolic links and it should work from the new location.


It’s ok, the problem was i didn’t offer administrator permission, now it function :), thank you guys.

1 Like

Awesome, happy it works now! I will make sure to mention this in the troubleshooting section of the manual.