Need help! Edit script no editor comes up

I am new to Armory and never done scripting before, but very interested in armory because of it’s seems to be fairly easy to use. I just want to be able to write traits. When I press edit node button, windows message comes up, “What program do you want to open with this?”. (My own words, don’t remember exact). I thought I would just put blender, but now when I press it just opens up blender again. I have searched the internet trying to figure out how to undo this, nothing works. I also want to know what I am suppose to use and how for editing codes? Please help! Thank you!!!

1 Like

Hi and welcome!

You can change the editor configuration in the Armory preferences, as explained here in the wiki:


I tried to follow the instructions on the site you gave me but it is still not working correctly. I took snippets of the error’s I get and the setup. I can use the nodes on armory but I cannot get Kode to come up.

python Error 2


KodeStudio (windows):


As @toot wrote, you need to select a text editor, not Krom. Krom is a runtime that runs your game, but you don’t use it to edit Haxe scripts.

Edit Tree will open the selected trait in the node editor in Blender (on the left in your screenshot) and not in another program. If you don’t see much it is probably because your logic tree has no nodes yet. If the name of the tree is displayed at the top of the node editor everything is fine :slight_smile:

From Editor will take the node tree that is opened in the node editor and will replace the trait’s tree with that.

There are a few wiki pages that can help you getting started:


I been slow to respond because I spent the last couple of days trying to get armory and blender functionable on a different account. I thought maybe if I started fresh it would help fix any problems I might of made in installing on main account. First of all I want to thank you for your help and quick responses! One of my problems is most of the tutorials on the subject are out of date. I am trying to follow along, but I need to know exactly what to push for a node editor or haxe editor to come up. I made sure that kode studio was selected in add on area. Because in my main account I tried pressing the edit code in the armory traits. Windows message kept coming up asking what program do you want to run with? So being ignorant I thought I’d try putting in blender thinking that blender was going be the program that is doing the coding for armory or whatever but that it would be functionable what I didn’t expect is every time I press the edit code button it would just re-open blender… I have tried to overwrite this in window’s settings but it doesn’t allow me to make changes or the changes don’t revert. So I am trying not to make the same mistake again. That is something I need to figure out how to fix. Mean while though I finally got Armory to work in one of my other accounts, it only works when I save my projects to Desktop. Why is this? On my main account I have been using a temp folder (not tmp.) Other than the issue of not being able to use a code editor everything has been working fine. I am sorry being so ignorant when it comes to this. I have been having fun with the armory but I just want to be able to write some simple codes for traits to see if I might be able to do the computer game I have been thinking about to go with my animation series (if I ever get that done)! Again Thank so much for patience and help!!!

1 Like

Got it to work!!! I ended up extracting kode studio files and stuck them in the same folder as Armory but not in the armory folder it’s self but next to. I opened up blender went to armory add on and went to the box below where I have Kode studio selected as editor to code editor executable and went to the kode studio exe. file and clicked on it. Saved re-opened went to click on edit script for a trait and it opened!!! :smile: Thank you for your input, I hope this can help someone out there, but I am sure going to need more help in the future!