Object leaves hideous after-image and other unpleasant visual effects

It would seem that my object can leave periodic after-images and tend to stripe like a cuttlefish hypnotizing its prey.

Maybe someone else is experiencing this problem? At any rate, I could use some help.

Some extra info:

happens on all of the few render options I’ve tried (including lightmap, although it happens infrequently there).

intel integrated graphics (I intend to keep using this, as I think it important to reach even the most terribly equipped of audiences)

It only happens on “fullscreen” (which is really just a maximized window for some reason). Otherwise, I suffer from only the stripes.

Many thanks to any who help, and, as always, long live Armory.

Maybe you’re experiencing culling issues?

Turned culling off under “Armory Render Path” 's “renderer” section. Seems to do nothing.

Do you have that little blurry ball in your blend?
or is it just resizing (eg full screen) issues?
I don’t get it…
Drop the .blend maybe??

somewhat untitled blend (691.3 KB)
Hopefully that clarifies things.

you may need to ensure that the trait “Net.hx” is unbound from the scene’s armory traits, I think I forgot to save that change before I uploaded.

Downloaded my own blend and ran it as a bare scene with only the spiked cube in the center, worked perfectly fine. It would seem not to happen without the script.
See here:
Net.hx (8.6 KB)
Built with C++, so Sys should be available.
Thanks for your patience.

Np… seems to fail to build…

Type not found: arm.Net
Crash reason…

Under Properties > Scene > Armory Traits it’s still attached, my bad. just unnatach it.

Sorry, can’t help…

maybe fixing parts like
function onUpdateSpawn(ob:Object) {
trace(“I’ll add a mesh later”);
would help…

That’s okay. I’ll probably chance upon my wrongdoing sooner or later.

its working on my end, with the error lines commented…

out of curiosity, which lines exactly? I know the server stuff shouldn’t work, but did you comment anything with updateObject or the mouse?

I just commented mouse and object update lines which were errors, exact thing.

Ah no, I forgot the script moves the camera backward, if I disable the script and move the camera back, I get the same issue, makes a lot of sense now. As you can see, there are still stripes.

So the issue is probably in the render path, I’ll try to tweak that and see if I chance on a workaround.
Thanks a lot, this narrows things down to my graphics setup…

Note to self, deferred render is broken until further notice.

In case this helps, armory 3D works on my PC only in Forward render mode.

How about volumetrics? Even in forward, which seems to work fine with surfaces, volumetrics seem to have similar issues.

looking through debug I found this:

Uniform lightColor not found.
Uniform envmapStrength not found.
Uniform shirr not found.
Uniform lightColor not found.
Uniform lightColor not found.
Uniform screenSize not found.
Uniform lightRadius not found.

I think it’s a shader error, but it doesn’t say which shader.