Permission error reports on Linux Mint 19.1 and SKD 2019.7

Hello Friends!
I’ve been having some permission issues with the most recent SDK 2019.7.
I’m on Linux Mint 19.1 and am setting up the SDK as an add-on (I don’t think that there is any other way now) on Blender 2.8 RC1.

The scene is a simple cube that I’ve saved to the desktop to avoid any kind of server (smb) permission errors but, even so, it’s giving permission errors.
I’ve attempted to change the permissions of the SDK and Project folders manually with the “chmod” terminal command but it didn’t work too.

Anyone knows what may be the problem?
Best regards

The same issue occurs even with the demo files:

yesterday I updated armory and I got problems with launching my game. It kept saying something like “Failed to compile…” and things like that. I didn’t know how to fix it and I went back to the version that I used a little before. Yeah, it has a problem with the sound which plays delayed, but at least I can launch and test my game.

Have you looked on GitHub if someone has the same problem as yours?

Hello Musa,
Thanks for your feedback! No I didn’t, but now that you mentioned it I’ll do so :slight_smile:
The last two versions, the 2019.6 and the 2019.7 both never worked for me as soon I hit “play”. :confused:

1 Like

That’s odd, I’m on Ubuntu and for me it worked straight away by putting it the home folder…

Did you use -R or --recursive when calling chmod?

Mine wasn’t on the Home folder, I had created a folder on the home folder called Armory SDK and inside it I have Armory SDK and Armory Paint… it was to keep things tidy :stuck_out_tongue:

After reading your comment I’ve attempted now to have it on the home folder directly but it returns the same error even so :confused:

Yes I did just that “chmod -R a+rwX ArmorySDK”


Where is the compiler being told to place its outputs? Look very closely at the compiler error messages or post them here.

Hey there MikeRobinson,
Thank you very much for your question!
Usually we would save the file and the files would go to the same place, no?
Here is the compiler error message:

Read prefs: /home/rogper/.config/blender/2.80/config/userpref.blend
found bundled python: /home/rogper/blender-2.80/2.80/python

<wmMsg_RNA 0x7fa3f6b58288, id=‘bpy_msgbus_subscribe_rna’, RenderSettings.engine values_len=1
<<<< bpy_msgbus_subscribe_rna

<wmMsg_RNA 0x7fa3f6b58288, id=‘bpy_msgbus_subscribe_rna’, RenderSettings.engine values_len=2
<<<< bpy_msgbus_subscribe_rna
Armory: Proxy objects synchronized
Read blend: /home/rogper/Desktop/TestingArmory2/Test.blend

<wmMsg_RNA 0x7fa3f8febbc8, id=‘bpy_msgbus_subscribe_rna’, RenderSettings.engine values_len=1
<<<< bpy_msgbus_subscribe_rna

Armory v2019.7 ($Id: 817bd37d712a58bf387b7808cccc5ae19cf6f534 $)
OS: linux, Target: krom, GAPI: opengl, Blender: 2.80 (sub 74)
Exporting Scene
Scene exported in 0.0060846805572509766
Exported modules: [‘audio’]
Shader flags: [’_Irr’, ‘_EnvCol’, ‘_Deferred’, ‘_ShadowMap’, ‘_CSM’, ‘_Sun’, ‘_SMAA’, ‘_SSAO’]
Traceback (most recent call last):
File “/home/rogper/Armory/ArmorySDK//armory/blender/arm/”, line 524, in execute
File “/home/rogper/Armory/ArmorySDK//armory/blender/arm/”, line 495, in play
compile(assets_only=(not wrd.arm_recompile))
File “/home/rogper/Armory/ArmorySDK//armory/blender/arm/”, line 276, in compile
File “/home/rogper/Armory/ArmorySDK//armory/blender/arm/lib/”, line 19, in run_haxe
haxe_server = subprocess.Popen([haxe_path, ‘–wait’, str(port)])
File “/home/rogper/blender-2.80/2.80/python/lib/python3.7/”, line 756, in init
restore_signals, start_new_session)
File “/home/rogper/blender-2.80/2.80/python/lib/python3.7/”, line 1499, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
PermissionError: [Errno 13] Permission denied: ‘/home/rogper/Armory/ArmorySDK//Kha/Tools/haxe/haxe-linux64’

location: :-1

location: :-1