Problem with Solidify

Yesterday I downloaded the Mac 06 version and updated my 06beta version. Running the armory 06 blender on my mac resulted in some strange material problems. I went back and did the following experiment.
(1) Test solidify with current blender2.8 from blender. The figure below shows what was created with three materials - just the usual stuff with solidify -works great. It used to work the same in the previous Armory3d 06 beta version.

(2) In a new file, re-created what I did in (1) above in the new Armory3D 06 for mac release.

The substance of the problem is that the materials no longer seem to work with solidify.


I don’t know anything that might be the cause right off, but aren’t those images just in Blender? It probably doesn’t have anything to do with Armory in that case, though the latest Armory may have come with a newer version of Blender that could behave differently. I couldn’t get the subsurface modifier to apply at all in the version of Blender 2.8 Beta that I have.

Yes, the problem probably does lie with 2.8. So, that said, since the solidify that doesn’t work is with the bundled new blender, I would guess that there is an interaction between the new blender that is bundled with armory 06 . The next on fixing it would probably take someone knowing about which version of blender 2.8 was bundled with armory 06. I imagine there is some type of interaction in the bundle…

Blender should tell you the commit hash in its splash page I think. :thinking: Also you should be able to use any recent version of Blender 2.8 and just use the Armory addon from your download with that version of blender if you want to do that.

Did some one get the addon version to work with 2.8, It hasn’t been and isn’t for me.

I’m using Blender 2.8 Beta (commit: 93a8556bf4b15) and I’m using the Git version of Armory and I’ve had it working for a while. What problem are you having?

I just tried it again. I had to remove and reinstall as add on and it worked.

1 Like

Thanks to Monte and Zicklag for having this conversation since it inspired me to use the git version of Armory and add it to a new version of 2.8 Blender (the one giving problems was downloaded in December). Eureka – all my problems disappeared after adding the GIT version of Armory to my Feb 10 build of Blender 2.8 . There had been some problem with the Materials that was erratic prior to my doing this change. Thanks, you-all…!!