Procedural Textures+Displacement/Bump does not work

a similar mistake has been hanging since September



if you search, you can find more. There is no solution anywhere.

Armory is in Early development. The current release version is only version 0.6 which should give you an idea about how far along the lead developer feels the project is at. It was only released as a project open to all last July.

Have some patience.

Creating a full blown game engine is a huge undertaking, and not every feature that everyone wants will be worked on straight away. That said, having been an issue for a while doesn’t mean that there are no plans to work on it eventually. Currently in 0.7 Lubos is working on another issue that was filed in September… 2017. There are strategic decisions about what gets worked on when, based on factors beyond just how much users want them. This is especially true before the release of a version that is considered fully ready for production use (and note, that is still a long way before a version considered to have most of the features of other, longer established engines.)

That’s not to say you can’t make and publish a game with Armory right now. Just understand that with any engine in this early start up phase, that you need to adapt your game around the engines abilities and not expect that the engine will already be able to adapt around the features you want for your game.

If you want to see things move faster then, great! Help out. Help out with code, or documentation, or funding or by giving the engine a good workout, showing what it can do and filing / adding info to constructive issues that help the devs.

In short, help out wherever you best can, in a way that most helps the devs.

In the long run, this is not only how you can best help Armory and it’s community, but how you can help give your game the best engine possible.

1 Like

Patience has nothing to do with it. I added a constructive question.
I temporarily replaced the Procedural textures, with regular ones, but it doesn’t look beautiful and weighs a lot. I added links to show that this question interests not me alone + has one root. Procedural textures in this use have a very large functionality, especially if add animation.

Maybe I’m missing something, but I literally don’t see any question anywhere in your post, which makes it tricky to provide help. I see a complaint that something doesn’t work and links to other places talking about the same thing and a statement that there is no solution.

What/where exactly is your question in the post?

Do you principal need a question mark? Did someone do something bad to you? You are very aggressive perceive. I do not want to offend you.
The question is right on the picture: why the changes are not transferred from the node of the wave to the Diffuse Shader? They go through the bump, and that bugs them get distortion?

Already tested, normal maps does not work in Armory pbr shader or Principle bdrf. Wait for next releases like 0.7 or best 1.0.

1 Like

Writing your question, probably would make things clearer.

Lol. No one here, including you, has done anything bad to me, and I’m not offended in the slightest bit. :slight_smile: Actually I was trying to understand what your question was to help you.

It’s a bug. It’s known. So at this point all any of us can do is either submit code, give money so Lubos can spend more time coding, find someone else to help with the code or… be patient and wait as MagicLord suggested (watching the issue on Github will at least get you notification when there’s activity on it though).