Hi, I was looking at build 12 examples when I saw this:

Under Armory Props, there is a shadeless button
In build 14, there is not.

How do I enable shadeless?


Check out the example at:

Some additional info:

The option can be found at Properties - Render - Armory Render Path - Materials - Solid.

1 Like

I guess that works, but now I can’t make certain objects shadeless to fake some effects I have in mind. is there any other way?

Yo, 'sup. The only way I see to do this as of currently is to hook up an Emission node to the output, but it seems like Armory’s post processing is rather strong, so the “usual” setup would require a really low emission strength. Even still, the color seems washed out.

If you have alpha an in image you’re using mapped to the “shadeless” object, then you’ll need to multiply the alpha by -1 and then add 1 to have it be usable.

EDIT: This isn’t true shadelessness, though, as it seems that emissive materials are still influenced by the environment and other lights. It’s no replacement for an actual per-material shadeless option. Hopefully that’ll be added in / explained soon.

My problem is that i am trying not to use voxel gi so that i can make games for people without a dedicated gpu, and i think emission shader requires voxel gi/ao.

I have Global Illumination off and it’s working, though.

Really? must have been an issue with build 14, then. Glad Lubos fixed it.

Yeah, Emissive shader seems to be the way to go atm, though as SolarLune mentions, it still gets a bit of influence from environmental lighting (as I think SolarLune mentioned).

Also of note (perhaps this should be a github issue) but using the Emission setting on the Armory PBR node doesn’t seem to work as expected as it always displays as pure white.

Armory PBR Node Emission:

Vanilla Cycles Emission: