Shadow sun bug

I started creating a first-person controller by following the armory 3d channel guide on YouTube.
Then I want to edit the environment of the world and put the sun, but when I look at one point of the world, the shadows go crazy, here is a link to a video that demonstrates this:

You might want to consider posting the blend. This is always a good way to avoid answers which appear to poke in the mist. Like, try to adjust some of the sun settings:

here is the .blend file:fps.blend (1.2 MB)

Works now. Will test it.

Seems to be due to your reflection plane. When i switch rendering for this plane off, everything works normal. No shadows flashing on and off. Either remove reflection plane or bake the shadows into texture. If the light does not move it will look even better.


Thank you, I will remember this so as not to repeat such mistakes again