[SOLVED] Blender 2.8 Node Behaviour Not Updating

I was walking my self through a Youtube tutorial using the object_rotate.blend file from the armory_examples-master folder. One thing I started to notice was that changes I made to the nodes, or if I added new behaviors didn’t show when I hit F5 to see it in game. The other thing I noticed was that after the game window pops up, the Node Tree selected in the Armory Traits would turn red. What does this mean? Is there some refresh that I need to do after making changes?
Using what ever version of 2.8 that comes with Armory.
Thanks for any help.

Just tried recreating the file from scratch in case there was something wrong with the source file I was using, and it happened again!
-I created nodes to make a cube rotate right or left.
-I was notified that I needed to save before launching player.
-Saved file.
-Launched Armory Player and it worked.
-Added nodes to make it rotate around another access.
-New behavior does not show! Not even after I save!
What am I missing? Anyone else come across this?

I think it just cache issue
Try clean building [click Clean button beside Play button, and then run(If some python error pop-up when clicking clean, just ignore it)]


I’ve had that issue with Armory 0.6 Git with Blender 2.8 Beta a few weeks ago. I was trying to track down the cause, but it was pretty random when it would or wouldn’t work. Restarting Blender would usually get it to rebuild the node trees and get the missing logic.

For memo if you modify in blender.py , you must restart Armory. Then you have to delete and add again the modified node in your node tree … otherwise the node is red.
If you modify only the node .hx , playing again is sufficient.

1 Like