[Solved] Demo examples are not working, and causes crashes on launch(Causes: OpenGL compatibility issue)

Hello, I downloaded example " Twin Stick Demo" and unziped in windows 10 (x64), install required components “vc_redist.x86.exe” and “vc_redist.x64.exe”, run example “game.exe”, but it does not run, crashed unknown error.
How to fix? Thanks!

Screenshot the error: https://i.imgur.com/SS6uOLv.png
Screenshot the installed components: https://i.imgur.com/bkm63Jp.png

Can’t help you with the error there. I don’t read russian, so can you please translate what is says.
Also, are you trying to export game or just running from blender? try running from both krom and browser from blender.

Program “game.exe” has stopped working

A problem caused the program to stop working correctly.
Windows will close the program and notify you if a solution is available.

Related topic – Cannot run ArmorPaint_04 win64 - What does this error message mean?
I should specifically note that I ran – http://armory3d.org/demo/armory_demo_win64.zip (I had the same problem)

Does it work for you now?
Its works very well for me.
Can’t say for sure error might be same both are different Armorpaint and Armory3d but since they share same export system. there might be bug.

@regexp Can you post your system info?
and try running https://github.com/armory3d/armory_templates/tree/master/twin_stick this in armory.

There is no information in the error, I don’t know how to look at the log (If run the cmd, there is also no information when falling).
I’m trying to run a standard example from the site:

Its work for me.
Its weird that there are no errors…hmmm…
Again, try running https://github.com/armory3d/armory_templates/tree/master/twin_stick this in armory, directly from armory blender not from .exe.

This for setting up armory-> https://armory3d.org/manual/#/getting_started/setup.

And once again show us your system info(Gpu, Cpu, Os, etc.)

CPU: Intel Core 2 Duo (P7550) 2.26GHz
GPU: ATI Mobility Radeon HD 4650 (1024 Mb)
RAM: 3 Gb (DDR3)
OS: Windows 10 (64 bit)

It works, if compiled with the settings of the mobile or low, another templates not work with any settings.

Working if compiled of render path “DirectX 11”, and not working if “Auto” or others.
^ only “Twin Stick” template, others not working.

I tested armory_demo_win64 on 4 PCs. It doesn’t work on one. They are nearly idential softwarewise, so I suspect it’s a hardware problem.

Hard problem is more likely. It look like people wit lower hardware support are having more problem.
Would have to collect more info on what is the minimum system requirements for a game to run on lowest graphics.

Well, windows event log entry associated with game.exe states that the application raised exception with code c0000005 which means it’s an “access memory violation”. Its probably faulty RAM then.

Well, if that what happen then, low RAM is problem, look like 3gb of RAM isn’t enough.
Can you tell all RAM amount across your 4 PCs you tried. and can you also tell amount of RAM does the pc have that does not work.

I have 10GB on PC where it is not working and 6, 8 and 8 where its working 🤷

You know, I even compiled debug version of one of the armory demos with the results I posted in – Cannot run ArmorPaint_04 win64 - What does this error message mean?
All https://github.com/armory3d/armory_templates are working, except celshade.
Before compilation I updated armory addon. I also tried different publishing pipeline presets (low/mobile etc), render paths (opengl/directx) and compilation modes (win32/x64/debug/release).

Yeah, we are well aware with celshade issue.

Can you try downloading and running(glview Opengl)-> http://realtech-vr.com/admin/glview.

and say opengl and directx version you are getting in the pc you are getting the error in?

Or come to discord so it is easier to communicate

(Protip: Unistall Chrome and use Firefox instead, Chrome hog memory very much while Firefox is smooth and fast).


GL report:

No task for directx.

Is this from PC where the demo doesnt work?
If yes, then it means that opengl isn’t compatible, your gpu/hardware opengl compatible version is 3.x while armory use 4.x.

1 Like

Yes it is. So @regexps case has probably the same cause, if directx is working for him.
There should be a GL check before application start rendering. Because some people download official demo, try, then turn their backs on armory.

1 Like

In this ->https://armory3d.org/download.html. There is already marked that OpenGl 4.4+ is recommended.
It just that nobody know who running what, can’t blame anyone on this ¯_(ツ)_/¯ .

1 Like