[SOLVED] Help with On Action Marker Node

Hi All,

I’ve been trying to use the On Action Marker node, but am struggling to create an action marker that is recognised by the node.

I’ve tried to replicate the setup in the Animation Actions example, but the markers used seem to have been binded to the action or something. The marker appears like the below image:
image

For comparison, my marker looks like this:
image
Notice that the marker is a triangle rather than a diamond and applies to the entire timeline rather than a single action.

Could this stop the marker from working?

Hi. Were you able to test with action stashing as I mentioned in my comment on GitHub?

Hi. Thanks, I just saw your reply. Let me look into it and I’ll get back to you :slight_smile:

It turns out that markers need to be pose markers. This can be found by opening a stashed action in the Action Editor and clicking menu Marker > Show Pose Markers. You can then add pose markers that are denoted with a diamond.

https://docs.blender.org/manual/en/latest/animation/markers.html#pose-markers

1 Like

Great, thanks for sharing! To clarify, you can play markers now at runtime in Armory?

Hi. Yes, I think so. I was basically able to trigger a print node when one of my character animation reached the marker.

2 Likes

Great! If possible, would you mind saying at the issue report that you created on GitHub that the problem has been solved and it wasn’t a bug and also close the issue? Thanks. :slightly_smiling_face:

2 Likes

I think the action marker solution is more of a workaround for the Github feature request. I might be able to get by using markers, but the NLA timeline makes blending animations, multiple animation layers and timing sounds more intuitive versus nodes I think.

I’m not sure how difficult or feasible it would be so to support NLA functionality in Armory. I can close it if it’s not applicable.

Ah, my mistake, I forgot that issue tracker of yours was for a feature request. I remember now that you created another thread in the past in the past that was originally for that issue. I confused this thread with that one, and thought the issue was a mislabeled bug tracker because you said this thread was solved.

No trouble at all. I did start a flurry of topics about the same time, so can understand how they got mixed up.

1 Like