[solved] How to use "set material image param" node?

I can’t use the node “set material image param” to change the image of a texture.
There is an example (armory_examples-master/material_params/params.blend), but I can’t get it work…
The example make reference to an image “tex1.png” that’s, I think, not present…
edit : it IS present in the “Bundled” folder, thanks @Naxela
I have noted that the target node has to have [Parameter] checked…

Can someone give a try on this ?


I haven’t tried, but I think it needs to be stored in the folder named “Bundled” in your project directory, since Armory automatically searches for assets within a folder with that name


you’re surely right. In the example, the images are stored in this folder.
But it’s still not working, and there is no error message.

Hmm, I can see that the example haven’t been updated lately, I’m not sure it’s working with the way of managing multiple image parameters as per the change: https://github.com/armory3d/armory/commit/b424b058bb90f293f59d847be12cd0f926fcd047#diff-dfc498955a82af51090320760588b7e2

Normally I’d think you should get a hxBytes error, but I can take a look when I get home

1 Like

Just tried to test it and the examples seems to work fine on my end:


(The left cube is based on uniform texture images)

I did get an error about some missing UV, but it still worked

1 Like

Glad you tried and got it working :slight_smile:
So it’s not a bug, I surely have a problem with my version of Armory, that’s not the first time…

edit : I updated the SDK, and it did not solve my problem…

edit 2 :
Uninstalled Armory, installed 2020.5.0 : not working,
Updated SDK : not working
Downloaded and extracted Armory examples on gihub : not working
Deleted Blender 2.82a folder, downloaded it, extracted : not working

I got the same animation on the center and the right cube, but not the left… I think I will have to forget this feature… Will use “Set material” node, if I can not change the texture.

final edit : working !

the error message about UV was a clue, I had to had texture coordinates to get it work.

thanks @Naxela
it was hard but your help was useful ! (and my system is now really updated)

1 Like